geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: HEADS-UP: ASM 3.1 shaded and org.objectweb.asm becomes org.apache.xbean.asm
Date Fri, 22 May 2009 16:39:07 GMT
Umm, why not upgrade xbean-reflect to asm 3.1?

thanks
david jencks

On May 22, 2009, at 6:55 AM, Jacek Laskowski wrote:

> Hi,
>
> I've just committed a new module xbean-asm-shaded and some ASM package
> changes (rev. 777524) to work around a known binary incompatibility
> between ASM 3.1 and former versions issue. XBean uses two ASM versions
> - 3.1 (xbean-finder) and 2.5.6 (xbean-reflect) which are incompatible.
> OpenEJB 3.1 uses xbean-finder quite extensively so when run together
> with Hibernate (as a JPA provider) that comes with ASM 2.5.6
> NoClassDefFoundErrors surface.
>
> The new maven project - xbean-asm-shaded - moves org.objectweb.asm to
> org.apache.xbean.asm.
>
> You've been warned. :)
>
> Jacek
>
> -- 
> Jacek Laskowski
> Notatnik Projektanta Java EE - http://www.JacekLaskowski.pl

Mime
View raw message