geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cameron Braid (JIRA)" <j...@apache.org>
Subject [jira] Commented: (XBEAN-88) Xbean incompatible with Spring-2.1-m2
Date Sun, 11 Nov 2007 13:13:50 GMT

    [ https://issues.apache.org/jira/browse/XBEAN-88?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12541624
] 

Cameron Braid commented on XBEAN-88:
------------------------------------

Yes, this issue does affect spring 2.5-rc1

Is there a plan for how xbean will support spring > 2.0 ?

> Xbean incompatible with Spring-2.1-m2
> -------------------------------------
>
>                 Key: XBEAN-88
>                 URL: https://issues.apache.org/jira/browse/XBEAN-88
>             Project: XBean
>          Issue Type: Bug
>    Affects Versions: 2.8, 3.0, 3.1, 3.2
>            Reporter: Cameron Braid
>
> I've been using ActiveMQ 4.1.1 with XBean 2.8 and Spring 2.0.5 without any issues.
> After upgrading to Spring-2.1-m2, using either xbean 2.8 or 3.0, I get this exception
:
> Caused by: java.lang.NoSuchMethodError: org.springframework.beans.factory.xml.XmlReaderContext.getReader()Lorg/springframework/beans/factory/xml/XmlBeanDefinitionReader;
> 	at org.apache.xbean.spring.context.v2c.XBeanNamespaceHandler.loadResource(XBeanNamespaceHandler.java:818)
> 	at org.apache.xbean.spring.context.v2c.XBeanNamespaceHandler.findNamespaceProperties(XBeanNamespaceHandler.java:778)
> 	at org.apache.xbean.spring.context.v2c.XBeanNamespaceHandler.parseBeanFromExtensionElement(XBeanNamespaceHandler.java:257)
> 	at org.apache.xbean.spring.context.v2c.XBeanNamespaceHandler.parse(XBeanNamespaceHandler.java:155)
> 	at org.apache.xbean.spring.context.v2.XBeanNamespaceHandler.parse(XBeanNamespaceHandler.java:49)
> 	at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1114)
> 	at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1104)
> 	... 36 more
> Spring 2.1-m2 appears to change the XmlReaderContext.getReader from
> public final org.springframework.beans.factory.xml.XmlBeanDefinitionReader getReader()
> to
> public final org.springframework.beans.factory.support.BeanDefinitionReader getReader()

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message