geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Build failure under jdk 1.4
Date Tue, 03 Oct 2006 15:30:27 GMT
I tried to build xbean trunk under jdk 1.4 and it complained about  
the qdox plugin:

[INFO]  
------------------------------------------------------------------------ 
----
[INFO] Building XBean :: Spring :: Common
[INFO]    task-segment: [clean, install]
[INFO]  
------------------------------------------------------------------------ 
----
[INFO] [clean:clean]
[INFO] Deleting directory /Users/david/geronimo/svn/geronimo/xbean/ 
trunk/xbean-spring-common/target
[INFO] Deleting directory /Users/david/geronimo/svn/geronimo/xbean/ 
trunk/xbean-spring-common/target/classes
[INFO] Deleting directory /Users/david/geronimo/svn/geronimo/xbean/ 
trunk/xbean-spring-common/target/test-classes
[INFO] [resources:resources]
[INFO] Using default encoding to copy filtered resources.
[INFO] [compiler:compile]
Compiling 44 source files to /Users/david/geronimo/svn/geronimo/xbean/ 
trunk/xbean-spring-common/target/classes
[INFO]  
------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO]  
------------------------------------------------------------------------
[INFO] Compilation failure

/Users/david/geronimo/svn/geronimo/xbean/trunk/xbean-spring-common/ 
src/main/java/org/apache/xbean/spring/generator/ 
QdoxMappingLoader.java:[35,-1] cannot access  
com.thoughtworks.qdox.JavaDocBuilder
bad class file: /Users/david/.m2/repository/qdox/qdox/1.6/qdox-1.6.jar 
(com/thoughtworks/qdox/JavaDocBuilder.class)
class file has wrong version 49.0, should be 48.0

Since there's a 1.5 profile I am tempted to think that a 1.4 build is  
supposed to work :-)

What's the plan for jdk 1.4 buildability?  Since geronimo is now  
using xbean-naming it would be nice if there was an easy way to build  
at least that under jdk 1.4

thanks
david jencks


Mime
View raw message