geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet" <gno...@gmail.com>
Subject FYI, Spring 2.0-rc3 incompatibility
Date Wed, 30 Aug 2006 14:20:45 GMT
I have just fixed the incompatibility with spring 2.0-rc3.

Unfortunately, the spring classes changed in an incompatible
way, as the signature of some overriden methods has changed.
To work around, that, I have splitted the xbean-spring-v2 in 3 modules,
which
are
   xbean-spring-v2 : base classes (we can only have one
XBeanNamespaceHandler implementation)
   xbean-spring-v2a : delegate classes for spring < 2.0-rc3
   xbean-spring-v2b : delegate classes for spring >= 2.0-rc3
The delegate classes are loaded at runtime, depending on the version used.

Everything seems to work now.
I also added a new module for intergration tests with spring 2.0-rc3.
-- 
Cheers,
Guillaume Nodet

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message