geronimo-xbean-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet" <gno...@gmail.com>
Subject Re: Classloading branch
Date Sun, 20 Aug 2006 22:12:03 GMT
Note that Xbean 2.6 has not been released yet, so if we want to keep
compatibility,
and if put it in 2.6, we need to make proxies wrt to 2.5 tag.

The main problem I see is that the class hierachy can not be maintained using
proxies, so I'm not sure if it's worth it.

On 8/20/06, Alan D. Cabrera <adc@toolazydogs.com> wrote:
> This makes sense to me.  Should we have thin, deprecated, proxies in the old package
or is that over the top?
>
>
> Regards,
> Alan
>
> Sent from my Verizon Wireless BlackBerry
>
> -----Original Message-----
> From: "Guillaume Nodet" <gnodet@gmail.com>
> Date: Sun, 20 Aug 2006 21:13:01
> To:xbean-dev@geronimo.apache.org
> Subject: Re: Classloading branch
>
> Should the xbean-classloaders module have a package named
>    org.apache.xbean.classloaders
> instead of keeping the old one
>    org.apache.xbean.server.classloader
>
> It would break compatibility, but if it deserved a new module ...
>
> On 8/20/06, Alan D. Cabrera <list@toolazydogs.com> wrote:
> > Alan D. Cabrera wrote:
> > > I'm going to take a crack at breaking out the classloading code into a
> > > separate module.  Should be simple enough.
> > >
> > > I'll solicit comments when I'm done and we can do an RTC vote
> > > afterwards, if all goes well.
> > >
> > Done, xbean/branches/classloader.  Comments anyone?
> >
> >
> > Regards,
> > Alan
> >
> >
> >
>
>
> --
> Cheers,
> Guillaume Nodet
>


-- 
Cheers,
Guillaume Nodet

Mime
View raw message