geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From frank pientka <frank.pien...@gmail.com>
Subject Re: Postgres/postgis problem: java.lang.ClassCastException: org.postgresql.util.PGobject cannot be cast to org.postgis.PGgeometry
Date Mon, 27 Jan 2014 07:53:02 GMT
because of changed classloading in Geronimo 3.0
I would recommend th following step
Create a datasource with webconsole, download PostgreSQL-JDBC there
and test it at the end
It's better to install the jdbc-driver separately from the application
as a system module in the respository
good luck
Frank

2014-01-26, Genc, Ă–mer <Oemer.Genc@iais.fraunhofer.de>:
> Hey there,
>
> I am having trouble in getting postgresql with extension postgis running
> under Geronimo 3.0.1.
> I have an application which worked fine under Geronimo 2.2.1. This
> application uses postgresql and postgis. With Geronimo 2.2.1 everything
> works as expected.
>
> However, migrating towards Geronimo 3.0.1 yields a ClassCastException,
> although  it is the exact same module.
>
> I have installed the postgres jdbc driver in Geronimo. I am able to run
> queries against my database from the webconsole of Geronimo.
> In my EAR module I have included the Postgres-9.1-903.jdbc.jar and the
> postgis-2.0.1.jar in the Class-Path entry of the modules MANIFEST.MF file.
> Everything is the same, as it was with Geronimo 2.2.1.
>
> However, it seems that these jars are not found during runtime. The
> deployment however succeeds.
>
> Anyone an idea, what else I could check?
>
> Thanks for any suggestions,
>
> Cheers,
>

Mime
View raw message