geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oleg Andreyev <oandre...@opensourcestrategies.com>
Subject Unable to set up ssl
Date Sat, 03 Aug 2013 15:22:05 GMT
Hi,

Last days I tried to set up SSL on Geronimo 3.0.1 and finally had to 
admit defeat.

My steps:

- Downloaded 3.0.1 (Linux x64, Web profile, run with Oracle JDK 1.6.0_14)
- Changed ports to 80/443 in config-substitution.properties
- Log in to Web console
- Created new keystore, enabled it, generated key, CSR, imported answer 
from CA

No errors so far. The key looks like:

Version:     3
Subject:     CN=xxx.yyyyy.com, OU=Domain Control Validated
Issuer:     SERIALNUMBER=10688435, CN=Starfield Secure Certification 
Authority, OU=http://certificates.starfieldtech.com/repository, 
O="Starfield Technologies, Inc.", L=Scottsdale, ST=Arizona, C=US
Serial Number:     2292395462585499
Valid From:     Fri Aug 02 20:15:19 EDT 2013
Valid To:     Wed Jul 30 16:46:03 EDT 2014
Signature Alg:     SHA1withRSA
Public Key Alg:     RSA
critical ext:     2.5.29.15
critical ext:     2.5.29.19
non-critical ext:     2.5.29.14
non-critical ext:     1.3.6.1.5.5.7.1.1
non-critical ext:     2.5.29.31
non-critical ext:     2.5.29.32
non-critical ext:     2.5.29.37
non-critical ext:     2.5.29.35
non-critical ext:     2.5.29.17

Also I have changed Web servers/TomcatWebSSLConnector to set correct 
keystoreFile and keystore password and stop/start it.

So, I tried connect with https and after some time "The connection was 
reset". And I see error in geronimo log:
2013-08-02 20:19:22,861 ERROR [JIoEndpoint]
java.lang.NullPointerException
     at 
org.apache.tomcat.util.net.JIoEndpoint.processSocket(JIoEndpoint.java:525)
     at 
org.apache.tomcat.util.net.JIoEndpoint$Acceptor.run(JIoEndpoint.java:230)
     at java.lang.Thread.run(Thread.java:619)

I describe this attempts because it is most appropriate to documentation 
but I tried different JDK, geronimo 3.0.0, keystore created by keytool 
and so on.

Any clue?

Mime
View raw message