geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "b.s" <x...@gmx.com>
Subject java.lang.IllegalStateException: No Factories configured for this Application
Date Wed, 12 Jun 2013 11:07:30 GMT
i   Apache Geronimo v3.0.1
ii  myfaces-bundle-1.1.10
iii Linux

*Required:* To successfully deploy an ear to Apache Geronimo v3.0.1.
*Problem:* java.lang.IllegalStateException: No Factories configured for this
Application.

java.lang.IllegalStateException: No Factories configured for this
Application. This happens if the faces-initialization does not work at all -
make sure that you properly include all configuration settings necessary for
a basic faces application and that all the necessary libs are included. Also
check the logging output of your web application and your container for any
exceptions!

If you did that and find nothing, the mistake might be due to the fact that
you use some special web-containers which do not support registering
context-listeners via TLD files and a context listener is not setup in your
web.xml.
A typical config looks like this;
<listener>
 
<listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
</listener>


1. In web.xml, I have this:

*  <context-param>
    <param-name>org.apache.myfaces.EXPRESSION_FACTORY</param-name>
    <param-value>com.sun.el.ExpressionFactoryImpl</param-value>
   </context-param>

<listener>
 
<listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
</listener>
*
Note:
1. Using only the Geronimo own myfaces-bundle-1.1.10.jar located in the
repository folder -- no other myfaces-bundle.x.x.x.jar in my ear.  
2. Removing the <context-param> or <listener> or both doesn't make any
difference to the error reported above.
3. The same ear file was succesfuly deployed on WASCE V3.0.0.3 with no
error.


Thanks for your help in advance.



--
View this message in context: http://apache-geronimo.328035.n3.nabble.com/java-lang-IllegalStateException-No-Factories-configured-for-this-Application-tp3986986.html
Sent from the Users mailing list archive at Nabble.com.

Mime
View raw message