geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Geronimo 3.0 backward compatibility for JEE 5 component
Date Tue, 05 Feb 2013 12:45:22 GMT

On Feb 4, 2013, at 3:06 PM, zilinchen <zilinchen@yahoo.com> wrote:

> Is Geronimo 3.0 backward compatibility for JEE 5 component?
> 
> such as web component JSP2.1/Servlet2.5 with MyFace 1.2.x implementation
> (JSF 1.2)
> 
> We have a web component works well on Geronimo 2.1, and looking for move it
> to Geronimo 3.0.
> As we have a third party library is based on JSF1.2 and can't be upgrade, So
> how can we deploy this JEE 5 component on 3.0 without upgrade JSF/JSP spec?

From a specification perspective, Java EE 6 is backward compatible with Java EE 5. Implementation
specifics (e.g. configuration settings, extensions, etc) may not necessarily be backward compatible.


Have you deployed your application on G 3.0 and are seeing problems?

--kevan
Mime
View raw message