geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcos Mendez <mar...@jitisoft.com>
Subject Re: strange car maven plugin errors
Date Thu, 10 Jan 2013 15:02:23 GMT
Resolved by adding to my pom.

<dependency>
    <groupId>org.apache.geronimo.specs</groupId>
    <artifactId>geronimo-ejb_3.1_spec</artifactId>
    <version>1.0.2</version>
</dependency>

Must have had it in my local repo originally.

Is it Friday yet?

8p

On Jan 10, 2013, at 9:35 AM, Marcos Mendez wrote:

> The problems seem to start starting org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2.

> 
> My old logs show this bundle starting without issues.
> 
> [org.apache.geronimo.system.configuration.DependencyManager] : Starting artifact: DependencyType
[org.apache.servicemix.bundles/org.apache.servicemix.bundles.xpp3/1.1.4c_3/jar:null]
> [org.apache.geronimo.system.configuration.DependencyManager] : Starting artifact: DependencyType
[org.apache.geronimo.specs/geronimo-jaxrpc_1.1_spec/2.1/jar:null]
> [org.apache.geronimo.system.configuration.DependencyManager] : Starting artifact: DependencyType
[org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2/jar:null]
> [org.apache.geronimo.system.configuration.DependencyManager] : Starting artifact: DependencyType
[org.apache.geronimo.specs/geronimo-j2ee-management_1.1_spec/1.0.1/jar:null]
> 
> I'm removing the m2/repo and starting from scratch and it fails. Not sure what this error
is:
> 
> [org.apache.geronimo.system.configuration.DependencyManager] : Could not install bundle
dependency
> org.apache.geronimo.kernel.config.NoSuchConfigException: org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2/jar
(configId: org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2/jar) (configId: org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2/jar)
> 
> Anyone having this problem? 
> 
> On Jan 9, 2013, at 10:48 PM, Marcos Mendez wrote:
> 
>> 
>> I've had my car working for a while (since last year). I start off a build today
and then I start getting these errors in our build server. I had to create a new local repo
to see the errors locally - my old repo seems to have stuff that works.
>> 
>> Did something get messed up in maven central???? Any ideas how to solve this? This
was working.
>> 
>> 
>> [org.apache.geronimo.system.configuration.DependencyManager] : Could not install
bundle dependency
>> org.apache.geronimo.kernel.config.NoSuchConfigException: org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2/jar
(configId: org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2/jar) (configId: org.apache.geronimo.specs/geronimo-ejb_3.1_spec/1.0.2/jar)
>> 
>> [org.apache.geronimo.system.configuration.DependencyManager] : Could not start bundle:
org.apache.geronimo.framework.rmi-naming_3.0.0 [13]
>> org.osgi.framework.BundleException: The bundle "org.apache.geronimo.framework.rmi-naming_3.0.0
[13]" could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.geronimo.blueprint;
version="0.0.0"
>> 
>> [org.apache.geronimo.system.configuration.DependencyManager] : Could not start bundle:
org.apache.geronimo.framework.plugin_3.0.0 [12]
>> org.osgi.framework.BundleException: Exception in org.apache.geronimo.kernel.osgi.ConfigurationActivator.start()
of bundle org.apache.geronimo.framework.plugin.
>> 	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
>> 
>> [ERROR] Could not load deployer configuration: org.apache.geronimo.framework/geronimo-gbean-deployer/3.0.0/car
>> org.apache.geronimo.framework/geronimo-gbean-deployer/3.0.0/car: ADD
>> org.apache.geronimo.framework/geronimo-gbean-deployer/3.0.0/car: READING
>> FINISHED
>> 
>> org.apache.geronimo.kernel.config.LifecycleException: load of org.apache.geronimo.framework/geronimo-gbean-deployer/3.0.0/car
failed
>> 	at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(SimpleConfigurationManager.java:316)
>> 
> 


Mime
View raw message