if you are talking about  https://issues.apache.org/jira/browse/GERONIMO-6186 

the patch there is to upgrade EJB to 3.1 and JPA to 2.0.   I don't know if it's allowed for a Java EE 5 application server.   IMHO, if the user wants EJB 3.1 and JPA 2.0 in G2.x,  he/she should provide a plugin for them instead of upgrading the default EJB 3.0 and JPA 1.0 in the server directly.

On Thu, Jul 19, 2012 at 7:40 PM, Kevan Miller <kevan.miller@gmail.com> wrote:

On Jul 19, 2012, at 5:33 AM, Shawn Jiang wrote:

> Thanks, David !
>
> Devs and Users, Any more inputs ?

There was the patch submitted that upgraded a number of Geronimo dependencies. IIRC, that's never been applied. I assume the major dependencies have been upgraded to current service levels (e.g. Tomcat, OpenEJB).

The changes in the patch may be more than we'd want in a 2.2.x release. I'd like a discussion to make sure that's what we want to do...

--kevan



--
Shawn