Hello all:

With a clean fresh install of Geronimo 2.2.1, and then going into Plugins, choosing the apache hosted OpenJPA2 repository and trying to install the appropriate plugins, you receive an error stating the system can't load openjpa-2.0.0-SNAPSHOT.  Upon further exploration it seems that file isn't current/hosted any longer.

To work around this it seems we have to modify the geronimo-plugins.xml file, self-host it somewhere, change the contents of it to identify a newer version of the OpenJPA and then host the jar in our own maven repository.  We tried changing the version to one that is currently hosted however it results in the same way stating that it can't find 2.0.0-SNAPSHOT.  It is unclear what is causing it to keep looking for 2.0.0 regardless of what is in the geronimo-plugins.xml.

Is it possible to get the apache hosted version of the plugins updates to point to valid references?

Thanks!
Josh