I find a way : use  inverse-classloading  in  deployment plans to tell geronimo to find class in war first

<sys:dependencies>


</sys:dependencies>
<sys:inverse-classloading/>
 </sys:environment>

read more  from :
https://cwiki.apache.org/GMOxDOC30/classloading.html

At 2011-12-10 21:35:55,changchang198009 <changchang198009@126.com> wrote:
env: win7  64bit   jdk 1.6.29 32bit , geronimo-3 beta1

How to use httpcomponents-client-4.1.2 in web app(war)????
IMy web app(war) uses httpcomponents-client-4.1.2 
I put 
"
commons-codec-1.4.jar
commons-logging-1.1.1.jar
commons-logging-adapters-1.1.1.jar
commons-logging-api-1.1.1.jar
httpclient-4.1.2.jar
httpclient-cache-4.1.2.jar
httpcore-4.1.2.jar
httpmime-4.1.2.jar   
log4j-1.2.16.jar
"
in context-root\WEB-INF\lib   and deploy the war,then get the log info:
"
Exception in thread "Thread-103" Exception in thread "Thread-105" java.lang.NoClassDefFoundError: org/apache/http/protocol/ImmutableHttpPro cessor
at org.apache.http.impl.client.AbstractHttpClient.getProtocolProcessor(AbstractHttpClient.java:656)
at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:804)
at org.apache.http.impl.client.AbstractHttpClient.execute(AbstractHttpClient.java:754)
"

if i put the jar to geronimo's reposity and add dependency for the war

the log is :

"
 Reason: Package uses conflict: Import-Package: org.apache.commons.httpclient; version="[3.1.0,3.1.0]", Package uses conflict: Import-Package
: org.apache.commons.httpclient.auth; version="[3.1.0,3.1.0]", Package uses conflict: Import-Package: org.apache.commons.httpclie
nt.u til; version="[3.1.0,3.1.0]", Package uses conflict: Import-Package: org.apache.http.impl.auth; version="[0.0.0,0.0.0]"

"

It seems that geronimo3 has  httpclient version 3.1 and my war has  httpclient  version 4.1.2 in it's lib ........

how to resolve the problem??