geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Radim Kolar <...@sendmail.cz>
Subject Re: classloading in 3.0
Date Wed, 09 Nov 2011 18:17:01 GMT
> What I'd actually like to see is that, instead of arbitrarily importing any particular
set of classes, we run bnd on the application classes to determine the Import-Packages needed.
This method is not that bad. but you need to be sure import javax.* 
classes from app server not from included jars. For example grails apps 
ships with jta api and it caused problems in G 2.1 and G 2.2 if this api 
was loaded from war and not from app server.

Do you ignore packages already included in WAR and dont import them 
again? Because on 3.0 spring applications fails with NPE. they not 
initialized properly, most likely because springs from geronimo are used.

Exploring classes leads to very slow deploys.

Probably best long term solution is to switch app development from WAR 
to WAB and use something simple like eclipse virgo or karaf.

Mime
View raw message