Could you please point out that which default SUN packages are used ? saaj impl ?
Have you tried to use the hidden-classes options mentioned in the doc ?

2011/9/23 adamruggles <>
I'm using Geronimo version 2.2 on JDK 1.6 (OSX 10.5).  I have a WAR project
that uses a newer version of CXF than the one included in Geronimo.  I can't
seem to get Geronimo to pickup the CXF implementation that I've included
with my project.  Instead it seems to be using the default SUN packages.
How do I override this?

Right now I have all my dependencies added to the Geronimo repository and
specified in my geronimo-web.xml file.

Thanks in advance.

View this message in context:
Sent from the Users mailing list archive at