geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Geronimo server stop when undeploy or redeploy.
Date Tue, 12 Jul 2011 15:56:17 GMT

On Jul 12, 2011, at 4:12 AM, ranbaab wrote:

> Hi Kevan,
> 
> There is no error message display, below is the command line for undeploy.
> 
> 
> D:\geronimo-tomcat6-minimal-2.2.1\bin>deploy --user system --password
> manager undeploy xxx/bhm/application/war
> Using GERONIMO_HOME:   D:\geronimo-tomcat6-minimal-2.2.1
> Using GERONIMO_TMPDIR: var\temp
> Using JRE_HOME:        D:\Software\IBM
> SDK\6.0\win32\ibm-java-sdk-60-win-i386\sdk\jre
> 
> It got stuck here....
> And another geronimo console which open, when given the command
> "start-server" does not print any log after giving the command.
> 
> And in the geronimo.log and deploy.log does not display any log message. I
> mean all got stuck.
> 
> But the UI display the message saying that the server is down.
> 
> Steps follow:
> 1. Start the database manually
> 2. Start the geronimo through the command line
> 3. Deploy the application through command line.
> 4. Undeploy through command line.
> 
> When I tried to delete the application folder from the repository before
> giving the undeploy command the folder cannot be delete. It display the
> message, the resources cannot be delete, it is being used by another
> program. I doubt whether the issue is when geronimo tried to delete the
> folder, same error might have occur.

OK. So, it sounds like the Geronimo server process is still running. It's just not responsive...

Can you generate java stacktraces for the server process? On a unix-like system, I'd use 'kill
-3 <process-id>'. 

--kevan
Mime
View raw message