geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Joysn <joys...@gmail.com>
Subject Re: Geronimo 2.2.1 with JSF 2
Date Wed, 29 Jun 2011 22:00:20 GMT
Hello Kevan,

thanks for your answer again. finally i have some success now, and the
problems had nothing todo
with Geronimo :)

i tried deploying the app to a normal tomcat6 installation and there i had
the same issues that the
webapp  did not work.
i created the faces project initially using maven and an archetype from
richfaces4, which created the
whole project layout and a simple demo app using a bean and a xhtml file
with an faces template.

unfortunately i did not verify the web.xml that was created during that
phase. The web.xml missed the
jsf servlet and the servlet mapping, only some richfaces context parameter
where in there. so with the
correct web.xml the webapp works now, in tomcat6 and in geronimo.

but i am still not able to deploy the webapp using Eclipse tooling, i need
to upload the war and the
deployment plan using the console. and, whether i give a deployment plan or
not, i need to prevent
the myfaces libs from loading into geronimo. so the deployment plan alone
does not do the trick.

however, i can run a jsf2 app now in geronimo. and there will be a solution
for the rest of the issues
as well... :)

thank u very much for your time and hints.

Chris

2011/6/29 Kevan Miller <kevan.miller@gmail.com>

>
> On Jun 29, 2011, at 4:39 PM, Chris Joysn wrote:
>
> > Hello Kevan,
> >
> > this Geronimo server is a cool thing :)
> >
> > i think i fixed the issue with the maven, eclipse and run on server
> issue:
> > i activated that the maven dependencies are exported as well at the
> projects settings.
> >
> > but:
> > i started with a fresh copy of Geronimo.
> > i added a geronimo-web.xml to WEB-INF/ with the content u provided
> > and when i deploy the project using the geronimo server adapter nothing
> happens
> > at geronimo. and there is no log message in the geronimo.log file. but
> the server
> > view in Eclipse shows the webapp running and [Synchronized]
> >
> > when i undeploy the webapp from the eclipses server view, add the
> geronimo-web.xml,
> > the webapp is deployed again, the logfile says:
> >
> > 2011-06-29 21:51:00,225 WARN  [TomcatModuleBuilder] Web application .
> does not contain a WEB-INF/geronimo-web.xml deployment plan.  This may or
> may not be a problem, depending on whether you have things like resource
> references that need to be resolved.  You can also give the deployer a
> separate deployment plan file on the command line.
> > 2011-06-29 21:51:00,250 INFO  [DeploymentContext] The Strict Manifest
> Classpath processing mode is in effect.
> > This option can be altered by specifying
> -DXorg.apache.geronimo.deployment.LenientMFCP=true|false
> > Specify ="true" for more lenient processing such as ignoring missing jars
> and references that are not spec compliant.
> >
> > and after a while the geronimo console shows the webapp up and running
> with the name of the context.
> > but i can not access it, tomcat shows a 404 for the context.
> >
> > again, not logfile entry besides the warning regarding the
> geronimo-web.xml...
> >
> > when i use the deployer from the geronimo web console and specify the war
> (containing the geronimo-web.xml) and the geronimo-web.xml as plan, then the
> webapp appears in the consoles Web App WARs view.
> > when i start the web app the web app is shown as running, but the context
> is not available, Tomcat shows again a 404.
> >
> > and, as usual, no log messages regarding the actions deployment,
> undeployment, why the context is not accessible...
> >
> > i dont have an idea whats going on...
>
> Hi Chris,
> Do you have a simple project that you can share? At a minimum, it seems
> that there is a deployment failure. And we could be doing a (much) better
> job of communicating the problem. May also be a problem in your app layout.
> Anyway, if you create a JIRA, and attach a zip file of your project.
> Hopefully, somebody can take a look at it...
>
> --kevan

Mime
View raw message