geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Joysn <joys...@gmail.com>
Subject Geronimo 2.2.1 with JSF 2
Date Sun, 26 Jun 2011 20:56:48 GMT
Hello,

i am a newbie on Geronimo and tried to get a JSF2 webapp up and running,
but it seems that i have some troubles with the Geronimo provided MyFaces
configuration.

yesterday i found a page where one wrote that the MyFaces components
in Geronimo should be deactivated because they are JSF 1.2 based.
But due to my deactivated browser history i can not find this page again
and so i tried to stop the system modules from the Geronimo console:

Stopped application
org.apache.geronimo.configs/myfaces-deployer/2.2.1/car
org.apache.geronimo.configs/myfaces/2.2.1/car

Unfortunately i get another exception from Geronimo when i try to deploy
the webapp:

2011-06-26 21:32:47,432 ERROR [web]] StandardWrapper.Throwable
java.lang.IllegalStateException: No Factories configured for this
Application. This happens if the faces-initialization does not work at all -
make sure that you properly include all configuration settings necessary for
a basic faces application and that all the necessary libs are included. Also
check the logging output of your web application and your container for any
exceptions!
If you did that and find nothing, the mistake might be due to the fact that
you use some special web-containers which do not support registering
context-listeners via TLD files and a context listener is not setup in your
web.xml.
A typical config looks like this;
<listener>

<listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>
</listener>

    at javax.faces.FactoryFinder.getFactory(FactoryFinder.java:106)
    at javax.faces.webapp.FacesServlet.init(FacesServlet.java:132)
    at
org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1065)
    at
org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:967)
    at
org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4343)
    at
org.apache.catalina.core.StandardContext.start(StandardContext.java:4649)

I dont know how to deal with that issue now...
Maybe the problem results from the way i deploy the webapp to Geronimo?

I use Eclipse 3.6.2 and the Geronimo 2.2.1 server adapter for deploying the
webapp. The webapp is a Maven based project which i imported to Eclipse
and then i set the facet Dynamic web module to the project.

If i look at the directory
$WORKSPACE/.plugins/org.apache.geronimo.st.v21.core then i find
a war file but there are no libs in the folder WEB-INF/lib...

Are they not deployed to Geronimo? Does Geronimo get the projects classpath
then i deploy the webapp to it?

Or am i wrong and i have another issue with Geronimo and JSF 2?

thanks in advance

Joysn

Mime
View raw message