geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Geronimo 2.2.1 with JSF 2
Date Wed, 29 Jun 2011 21:17:54 GMT

On Jun 29, 2011, at 4:39 PM, Chris Joysn wrote:

> Hello Kevan,
> 
> this Geronimo server is a cool thing :)
> 
> i think i fixed the issue with the maven, eclipse and run on server issue:
> i activated that the maven dependencies are exported as well at the projects settings.
> 
> but:
> i started with a fresh copy of Geronimo.
> i added a geronimo-web.xml to WEB-INF/ with the content u provided
> and when i deploy the project using the geronimo server adapter nothing happens
> at geronimo. and there is no log message in the geronimo.log file. but the server
> view in Eclipse shows the webapp running and [Synchronized]
> 
> when i undeploy the webapp from the eclipses server view, add the geronimo-web.xml,
> the webapp is deployed again, the logfile says: 
> 
> 2011-06-29 21:51:00,225 WARN  [TomcatModuleBuilder] Web application . does not contain
a WEB-INF/geronimo-web.xml deployment plan.  This may or may not be a problem, depending on
whether you have things like resource references that need to be resolved.  You can also give
the deployer a separate deployment plan file on the command line.
> 2011-06-29 21:51:00,250 INFO  [DeploymentContext] The Strict Manifest Classpath processing
mode is in effect.
> This option can be altered by specifying -DXorg.apache.geronimo.deployment.LenientMFCP=true|false
> Specify ="true" for more lenient processing such as ignoring missing jars and references
that are not spec compliant.
> 
> and after a while the geronimo console shows the webapp up and running with the name
of the context. 
> but i can not access it, tomcat shows a 404 for the context.
> 
> again, not logfile entry besides the warning regarding the geronimo-web.xml...
> 
> when i use the deployer from the geronimo web console and specify the war (containing
the geronimo-web.xml) and the geronimo-web.xml as plan, then the webapp appears in the consoles
Web App WARs view.
> when i start the web app the web app is shown as running, but the context is not available,
Tomcat shows again a 404.
> 
> and, as usual, no log messages regarding the actions deployment, undeployment, why the
context is not accessible...
> 
> i dont have an idea whats going on...

Hi Chris,
Do you have a simple project that you can share? At a minimum, it seems that there is a deployment
failure. And we could be doing a (much) better job of communicating the problem. May also
be a problem in your app layout. Anyway, if you create a JIRA, and attach a zip file of your
project. Hopefully, somebody can take a look at it...

--kevan
Mime
View raw message