geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: ERROR [AbstractEncryption] Unable to decrypt
Date Mon, 06 Jun 2011 02:28:03 GMT

On Jun 5, 2011, at 3:29 PM, 4lorn wrote:

> Kevan,
> 
> May you have all the delicious joe you can ever get into your mug.  I can't believe how
fast you responded (and on a Sunday (my time) no less)!
> 
> I ran:
> $sudo JAVA_HOME=/usr/lib/jvm/java-6-sun ./geronimo.sh run --long
> 
> Same result, encryption error.

Hmm. Did the error message change? I would have expected a "ERROR [AbstractEncryption] Unable
to decrypt" message instead of a NoSuchAlgorithmException...


> 
> I then downloaded a farm-fresh installation of Geronimo, validated, unpacked, and ran
exactly the same command against the new directory.  Success!
> 
> I believe the original error confirms the issue previous posters in the thread encountered.
 Whether the path to JAVA_HOME was explicitly called out or not, once a bad shell command
to run Geronimo was executed, the installation became corrupt, and no amount of pointing to
the correct JAVA_HOME path would fix it.
> 
> As for my environment, /usr/bin/java is as you guessed, a symbolic link.  It links to
/etc/alternatives/java, which in turn, links to the actual JAVA_HOME.  I doubt that link-nesting
could cause a problem, but I've been wrong before.

Me too.. Anyway -- great that it's working for you, now.

--kevan

Mime
View raw message