geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Help with G3.0 building
Date Tue, 07 Jun 2011 23:21:08 GMT

On Jun 7, 2011, at 6:51 PM, Russell E Glaue wrote:

> 
> 
> On 06/07/2011 05:08 PM, Kevan Miller wrote:
>> 
>> On Jun 7, 2011, at 5:48 PM, Russell E Glaue wrote:
>> 
>>> I had originally done the install 'mvn clean install' yesterday, and received
a
>>> build error. I then did it in the two stages and got the same results.
>>> That is why I ended up executing mvn compile and package separately so I could
>>> see if the error was in the compiling stage or the packaging stage.
>>> 
>>> I just updated the svn repo, issued 'mvn clean install' again, on trunk revision
>>> 1133142 and received the same error message.
>>> 
>>> (Note, for finish time, the system time is way off, -06:10)
>>> -
>>> [org.apache.geronimo.gbean.runtime.GBeanInstanceState] : GBeanInstanceState for:
>>> org.apache.geronimo.configs/uddi-tomcat/3.0-SNAPSHOT/car?configurationName=org.apache.geronimo.configs/uddi-tomcat/3.0-SNAPSHOT/car
>>> State changed from stopping to stopped
>>> [INFO] ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] could not package plugin
>>> 
>>> Embedded error: Unable to generate the wsdl file using wsgen.
>>> com.sun.tools.ws.spi.WSToolsObjectFactory in classloader null
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] For more information, run Maven with the -e switch
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Total time: 67 minutes 10 seconds
>>> [INFO] Finished at: Tue Jun 07 11:19:26 EDT 2011
>>> [INFO] Final Memory: 475M/742M
>>> [INFO] ------------------------------------------------------------------------
>>> [ger@linux7 asf-geronimo-server-trunk]# history | tail -2
>>> 192  mvn clean install
>>> 193  history | tail -2
>>> [ger@linux7 asf-geronimo-server-trunk]# svn info
>>> Path: .
>>> URL: https://svn.apache.org/repos/asf/geronimo/server/trunk
>>> Repository Root: https://svn.apache.org/repos/asf
>>> Repository UUID: 13f79535-47bb-0310-9956-ffa450edef68
>>> Revision: 1133142
>>> Node Kind: directory
>>> Schedule: normal
>>> Last Changed Author: gawor
>>> Last Changed Rev: 1133030
>>> Last Changed Date: 2011-06-07 10:43:37 -0400 (Tue, 07 Jun 2011)
>>> 
>>> [ger@linux7 asf-geronimo-server-trunk]#
>>> -
>>> 
>>> I am compiling with java version "1.6.0_25"
>>> I am not using the nexus proxy server.
>>> I have downloaded and installed all maven dependencies which maven itself was
>>> not able to connect to a repo to download.
>> 
>> Thanks for all the info! One additional question: what version of maven are you using?
>> 
>> The latest automated build worked -- http://ci.apache.org/builders/geronimo-server-trunk/builds/63
-- well, the Testsuite tests had some failures that weren't recorded properly, but can ignore
that for now...
>> 
>> Do you have an SDK or a JSE installed? wsgen would only come with an SDK. So, if
you only have a JSE, that would explain the failure.
>> 
>> --kevan
> 
> Yes, I am running the "SE" or "Standard Edition" of Java - the full JDK bundle
> of the J2SE6.
> https://cwiki.apache.org/GMOxDEV/building-apache-geronimo.html
> The documentation says "You will need a JDK 5.0+ (J2SE 1.5.0+) or compatible JDK
> to build Apache Geronimo. ..."
> 
> I actually considered that I should be using the Java EE SDK (this what you mean
> right?) but the Geronimo Development documentation did not state that. The docs
> say to use the JDK, and specifically the "J2SE".
> So... I have been trying to get G3.0 to compile with only the JDK.


Right. So, I chose my acronyms unwisely. Let me try again. 

You should build with a JAVA SE JDK, not a JRE.  

You don't want/need the Java EE SDK. Sorry for the confusion.

> 
> I am using the Java SE 6u26, JDK 1.6.0_25
> I am using the latest version of Maven 2, 2.2.1
> 
> I tried one time with Maven 3, but G3.0 did not compile successfully. So I
> reverted to 2.2.1 which is documented to use, on the Wiki.
> https://cwiki.apache.org/GMOxDEV/building-apache-geronimo.html
> "...For 3.0, you need [maven] version 2.2.1 or later. ..."
> 
> I am actually building G3.0 Successfully. And all the test suites seem to be
> successful (no failures yet). Just this one very odd occurrence.

Can you post more of the build output near the failure? I don't have a clear picture of where
in the build process you're getting this failure.

You might find it easier to create a Jira and attach the failure info to the Jira. Up to you...

I'm mostly building with maven 3. I asked about your maven version only to try and pin down
the source of your failure...

<snip>

> I can update the wiki page "Building Apache Geronimo" with the resulting
> configuration I have for G3.0 if I can actually succeed in this.
> This will be a good test case for a novice approach to compiling G3.0 for those
> who would be strictly following the documentation.

That would be great. We're happy to give people write access to our Wiki. We do, however,
ask that an ICLA be submitted -- http://www.apache.org/licenses/#clas The insures any documentation
contributions can be properly distributed under an Apache License. If you do submit an ICLA
-- simplest technique is to print, fill out, scan and email the pdf to secretary@. This can
be quite fast turn-around. 

--kevan


Mime
View raw message