geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Help with G3.0 building
Date Tue, 07 Jun 2011 22:08:12 GMT

On Jun 7, 2011, at 5:48 PM, Russell E Glaue wrote:

> I had originally done the install 'mvn clean install' yesterday, and received a
> build error. I then did it in the two stages and got the same results.
> That is why I ended up executing mvn compile and package separately so I could
> see if the error was in the compiling stage or the packaging stage.
> 
> I just updated the svn repo, issued 'mvn clean install' again, on trunk revision
> 1133142 and received the same error message.
> 
> (Note, for finish time, the system time is way off, -06:10)
> -
> [org.apache.geronimo.gbean.runtime.GBeanInstanceState] : GBeanInstanceState for:
> org.apache.geronimo.configs/uddi-tomcat/3.0-SNAPSHOT/car?configurationName=org.apache.geronimo.configs/uddi-tomcat/3.0-SNAPSHOT/car
> State changed from stopping to stopped
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] could not package plugin
> 
> Embedded error: Unable to generate the wsdl file using wsgen.
> com.sun.tools.ws.spi.WSToolsObjectFactory in classloader null
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 67 minutes 10 seconds
> [INFO] Finished at: Tue Jun 07 11:19:26 EDT 2011
> [INFO] Final Memory: 475M/742M
> [INFO] ------------------------------------------------------------------------
> [ger@linux7 asf-geronimo-server-trunk]# history | tail -2
>  192  mvn clean install
>  193  history | tail -2
> [ger@linux7 asf-geronimo-server-trunk]# svn info
> Path: .
> URL: https://svn.apache.org/repos/asf/geronimo/server/trunk
> Repository Root: https://svn.apache.org/repos/asf
> Repository UUID: 13f79535-47bb-0310-9956-ffa450edef68
> Revision: 1133142
> Node Kind: directory
> Schedule: normal
> Last Changed Author: gawor
> Last Changed Rev: 1133030
> Last Changed Date: 2011-06-07 10:43:37 -0400 (Tue, 07 Jun 2011)
> 
> [ger@linux7 asf-geronimo-server-trunk]#
> -
> 
> I am compiling with java version "1.6.0_25"
> I am not using the nexus proxy server.
> I have downloaded and installed all maven dependencies which maven itself was
> not able to connect to a repo to download.

Thanks for all the info! One additional question: what version of maven are you using?

The latest automated build worked -- http://ci.apache.org/builders/geronimo-server-trunk/builds/63
-- well, the Testsuite tests had some failures that weren't recorded properly, but can ignore
that for now...

Do you have an SDK or a JSE installed? wsgen would only come with an SDK. So, if you only
have a JSE, that would explain the failure.

--kevan
Mime
View raw message