geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: GBeans fails with missing dependency, but it's shown in the Console
Date Thu, 28 Apr 2011 20:09:41 GMT
I don't recall if there's something unusual about how 2.0.1 was set up but normally you want
to use one of the scripts in bin rather than trying to start a jar directly.  There's quite
a bit of setup involved.  

I hope the documentation has more info....

thanks
david jencks

On Apr 28, 2011, at 9:46 AM, WinnieNicklaus wrote:

> So, all three of the following fail with that error message:
> 
> java -jar <geronimo_home>/bin/deployer.jar --user <system> --password
> <password> deploy resources_deployment_plans/deploy_ds.xml
> <geronimo_home>/repository/org/tranql/tranql-connector-ra/1.3/tranql-connector-ra-1.3.rar
> 
> java -jar <geronimo_home>/bin/deployer.jar --user <system> --password
> <password> deploy resources_development_plans/deploy_jms.xml
> <geronimo_home>/repository/org/apache/geronimo/modules/geronimo-activemq-ra/2.0.1/geronimo-activemq-ra-2.0.1.rar
> 
> java -jar <geronimo_home>/bin/deployer.jar --user <system> --password
> <password> deploy eP-EAR.ear
> ***************************
> The contents of deploy_ds.xml:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <connector xmlns="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2">
>    <dep:environment
> xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2">
>        <dep:moduleId>
>            <dep:groupId>console.dbpool</dep:groupId>
>            <dep:artifactId>epims_ds</dep:artifactId>
>            <dep:version>1.0</dep:version>
>            <dep:type>rar</dep:type>
>        </dep:moduleId>
>        <dep:dependencies>
>            <dep:dependency>
>                <dep:groupId>lib</dep:groupId>
>                <dep:artifactId>postgresql</dep:artifactId>
>                <dep:version>8.1.407.jdbc3</dep:version>
>                <dep:type>jar</dep:type>
>            </dep:dependency>
>        </dep:dependencies>
>    </dep:environment>
>    <resourceadapter>
>        <outbound-resourceadapter>
>            <connection-definition>
> 
> <connectionfactory-interface>javax.sql.DataSource</connectionfactory-interface>
>                <connectiondefinition-instance>
>                    <name>epims_ds</name>
>                    <config-property-setting
> name="Password"></config-property-setting>
>                    <config-property-setting
> name="Driver">org.postgresql.Driver</config-property-setting>
>                    <config-property-setting
> name="UserName">postgres</config-property-setting>
>                    <config-property-setting
> name="ConnectionURL">jdbc:postgresql://127.0.0.1/ePimsDB</config-property-setting>
>                    <connectionmanager>
>                        <local-transaction/>
>                        <single-pool>
>                            <max-size>10</max-size>
>                            <min-size>0</min-size>
>                            <match-one/>
>                        </single-pool>
>                    </connectionmanager>
>                </connectiondefinition-instance>
>            </connection-definition>
>        </outbound-resourceadapter>
>    </resourceadapter>
> </connector>
> ******************************
> The contents of deploy_jms.xml are similar, but longer, so I won't post them
> right now.  This is a dependency in it, however:
> 
>        <dep:dependencies>
>            <dep:dependency>
>                <dep:groupId>org.apache.geronimo.configs</dep:groupId>
>                <dep:artifactId>activemq-broker</dep:artifactId>
>                <dep:type>car</dep:type>
>            </dep:dependency>
>        </dep:dependencies>
> 
> *****************************
> eP-EAR.ear is the ear for the application.  As for using 2.0.1, the
> application is somewhat old and not actively developed, and the
> documentation for it says it was tested on Geronimo 2.0.1, so I figure
> that's what I ought to stick with.
> 
> Any ideas?  Thanks much!
> 
> --
> View this message in context: http://apache-geronimo.328035.n3.nabble.com/GBeans-fails-with-missing-dependency-but-it-s-shown-in-the-Console-tp2871955p2875416.html
> Sent from the Users mailing list archive at Nabble.com.


Mime
View raw message