geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Same problem on Lenny Re: java.security.NoSuchAlgorithmException on Windows
Date Sun, 20 Mar 2011 15:27:31 GMT

On Mar 18, 2011, at 7:25 PM, weberjn wrote:

> I ran into the same problem on Debian Lenny in a 32 bit vserver, no idea
> what's wrong. JBoss 6 runs fine from the same command prompt, so no problem
> with Java, I guess. Before I ran a Ubuntu 10.4 64 bit on the same VM,
> Geronimo ran fine. After reinstalling to Lenny 32 bit there was the problem.
> (I switched to 32 because of the much smaller memory footprint)
> 
> weberjn@lenny:~/geronimo-tomcat6-javaee5-2.2.1/bin$ which java
> /usr/local/java/bin/java
> weberjn@vs534:~/geronimo-tomcat6-javaee5-2.2.1/bin$ file `which java`
> /usr/local/java/bin/java: ELF 32-bit LSB executable, Intel 80386, version 1
> (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not
> stripped
> weberjn@lenny:~/geronimo-tomcat6-javaee5-2.2.1/bin$ echo $JAVA_HOME
> /usr/local/java
> weberjn@lenny:~/geronimo-tomcat6-javaee5-2.2.1/bin$ java -version
> java version "1.6.0_24"
> Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
> Java HotSpot(TM) Client VM (build 19.1-b02, mixed mode, sharing)
> weberjn@lenny:~/geronimo-tomcat6-javaee5-2.2.1/bin$ echo $JRE_HOME
> 
> weberjn@lenny:~/geronimo-tomcat6-javaee5-2.2.1/bin$  ll /usr/local/java
> lrwxrwxrwx 1 root staff 11 2011-03-18 23:07 /usr/local/java -> jdk1.6.0_24
> weberjn@lenny:~/geronimo-tomcat6-javaee5-2.2.1/bin$ ./geronimo.sh run
> Using GERONIMO_HOME:   /home/weberjn/geronimo-tomcat6-javaee5-2.2.1
> Using GERONIMO_TMPDIR: var/temp
> Using JRE_HOME:        /usr/local/java
> /usr/local/java/bin/java
> Booting Geronimo Kernel (in Java 1.6.0_24)...
> Starting Geronimo Application Server v2.2.1
> [*****                                   ]  13%   1s  Loading
> org.apache.ger...2011-03-19 00:03:07,297 ERROR [AbstractEncryption] Unable
> to decrypt
> java.security.NoSuchAlgorithmException: Cannot find any provider supporting
> AES
>        at javax.crypto.Cipher.getInstance(DashoA13*..)

What is in your '/usr/local/java//lib/ext' directory? geronimo.sh is going to construct that
as part of the -Djava.ext.dirs= setting passed to java. I expect that the directory does not
exist/or does not contain any jars on your Lenny system.

What happens if you configure JAVA_HOME=/usr/local/jdk1.6.0_24? Does /usr/local/jdk1.6.0_24/lib/ext
exist and contain jar files (e.g. sunjce_provider.jar)?

I expect that sorting out your JAVA_HOME setting may well fix your problem. If not, then let
us know... It looks like to me that we no longer need to be configuring -Djava.ext.dirs at
all. So, we could do some cleanup of geronimo.sh/.bat... You're welcome to create a Jira (and
submit a patch, if you're interested).

--kevan





Mime
View raw message