I didn't see any problems neither with the geronimo-web.xml nor web.xml file.  And I just tried on my machine with the exact steps on Geronimo2.2 and it works as expected.

If you were using 3.0M1 or later versions, --inPlace is not supported yet and we already have a JIRA(1) for it.

Please try with 2.2 or 2.1.* versions.

(1). https://issues.apache.org/jira/browse/GERONIMO-5488

HTH.

Jeff


On Tue, Sep 14, 2010 at 6:47 PM, chi runhua <chirunhua@gmail.com> wrote:
Which version of Geronimo you are using?

Jeff


On Tue, Sep 14, 2010 at 6:11 PM, albu77 <albu.consult@gmail.com> wrote:

I'm starting with Geronimo, install it, started oK
Try the demo as exposed on:
https://cwiki.apache.org/GMOxDOC22/quick-start-apache-geronimo-for-the-impatient.html#Quickstart-ApacheGeronimofortheimpatient-Startingtheserver

When I want to deploy with
deploy --user system --password manager deploy --inPlace applications

I get an error message:

c:\Apache\Geronimo\bin>deploy --user system --password manager deploy
--inPlace
c:\Apache\Geronimo\applications
Using GERONIMO_HOME:   c:\Apache\Geronimo
Using GERONIMO_TMPDIR: var\temp
Using JRE_HOME:        C:\Program Files\Java\jre6
2010-09-14 10:27:33,594 ERROR [DeployTool] Error:
org.apache.geronimo.common.DeploymentException: Unable to deploy
applications: E
rror parsing web.xml for .
       error: Unexpected element: CDATA
       Unexpected element: CDATA

       at
org.apache.geronimo.deployment.cli.CommandDeploy.runCommand(CommandDe
ploy.java:45)
       at
org.apache.geronimo.deployment.cli.CommandDistribute.executeOnline(Co
mmandDistribute.java:149)
       at
org.apache.geronimo.deployment.cli.CommandDistribute.execute(CommandD
istribute.java:125)
       at
org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java
:168)
       at
org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(Ma
inConfigurationBootstrapper.java:45)
       at
org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
       at
org.apache.geronimo.cli.deployer.DeployerCLI.main(DeployerCLI.java:31
)


c:\Apache\Geronimo\bin>


I don't understand I paste the code from the site concerning the two xml
file, even pass them through NotePad++ to avoid bad characters insertion..
Restarted the server after saving the files from the Editor.

Can somebody have a an advise.

Regards

Alain

geronimo-web-xml:
<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
   <environment>
       <moduleId>
           <groupId>org.apache.geronimo.samples</groupId>
           <artifactId>HelloWorldApp</artifactId>
           <version>2.2</version>
           <type>war</type>
       </moduleId>
   </environment>
   <context-root>/hello</context-root>
</web-app>


web.xml:
<?xml version="1.0" encoding="UTF-8"?>
<web-app version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
   <welcome-file-list>
       <welcome-file>HelloWorld.jsp</welcome-file>
   </welcome-file-list>
</web-app>
--
View this message in context: http://apache-geronimo.328035.n3.nabble.com/Newbie-problem-with-web-xml-tp1472065p1472065.html
Sent from the Users mailing list archive at Nabble.com.