geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shailen <khichi.shailen...@gmail.com>
Subject Re: problem starting geronimo
Date Fri, 20 Aug 2010 13:32:35 GMT
  Hey Ivan,

Thanks for your suggestions. I would try your suggestion and would 
update you about the proceedings.

Regards,
Shailen (khichi.shailendra@gmail.com)
Mohali, Chandigarh - 160062


On Friday 20 August 2010 07:00 PM, Ivan wrote:
> Check this JIRA https://issues.apache.org/jira/browse/GERONIMO-5175
> Aslo, after googled 1.6.0-b105,  it is a very early version JDK 1.6, I 
> could see someone asked related question in 2007. I would still 
> suggest you use latest JDK 1.6 or 1.5.
> Hope it helps.
>
> 2010/8/20 Shailen <khichi.shailendra@gmail.com 
> <mailto:khichi.shailendra@gmail.com>>
>
>     I found that open jdk was also installed on that machine .
>     Removed that as well .. also installed the fresh sun jdk(same
>     1.6.0.. as after oracle they ask for registration to install :( )
>     .. and got the same error.
>     Error trace from geronimo.log is as follows:
>
>     2010-08-20 15:51:45,181 INFO  [Log4jService] Started Logging Service
>     2010-08-20 15:51:45,182 INFO  [Log4jService] Runtime Information:
>     2010-08-20 15:51:45,183 INFO  [Log4jService]   Install Directory =
>     /opt/geronimo-tomcat6-javaee5-2.2
>     2010-08-20 15:51:45,185 INFO  [JvmVendor] Sun JVM 1.6.0
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   JVM in use        =
>     Sun JVM 1.6.0
>     2010-08-20 15:51:45,185 INFO  [Log4jService] Java Information:
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [java.runtime.name <http://java.runtime.name>]     = Java(TM) SE
>     Runtime Environment
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [java.runtime.version]  = 1.6.0-b105
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [os.name <http://os.name>]               = Linux
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [os.version]            = 2.6.32-21-generic
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [sun.os.patch.level]    = unknown
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [os.arch]               = i386
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [java.class.version]    = 50.0
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [locale]                = en_IN
>     2010-08-20 15:51:45,185 INFO  [Log4jService]   System property
>     [unicode.encoding]      = UnicodeLittle
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [file.encoding]         = UTF-8
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.vm.name <http://java.vm.name>]          = Java HotSpot(TM)
>     Server VM
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.vm.vendor]        = Sun Microsystems Inc.
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.vm.version]       = 1.6.0-b105
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.vm.info <http://java.vm.info>]          = mixed mode
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.home]             = /opt/jdk1.6.0/jre
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.classpath]        = null
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.library.path]     =
>     /opt/jdk1.6.0/jre/lib/i386/server:/opt/jdk1.6.0/jre/lib/i386:/opt/jdk1.6.0/jre/../lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.endorsed.dirs]    =
>     /opt/geronimo-tomcat6-javaee5-2.2/lib/endorsed:/opt/jdk1.6.0/jre//lib/endorsed
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [java.ext.dirs]         =
>     /opt/geronimo-tomcat6-javaee5-2.2/lib/ext:/opt/jdk1.6.0/jre//lib/ext
>     2010-08-20 15:51:45,186 INFO  [Log4jService]   System property
>     [sun.boot.class.path]   =
>     /opt/geronimo-tomcat6-javaee5-2.2/lib/endorsed/yoko-rmi-spec-1.0.jar:/opt/geronimo-tomcat6-javaee5-2.2/lib/endorsed/yoko-spec-corba-1.0.jar:/opt/jdk1.6.0/jre/lib/resources.jar:/opt/jdk1.6.0/jre/lib/rt.jar:/opt/jdk1.6.0/jre/lib/sunrsasign.jar:/opt/jdk1.6.0/jre/lib/jsse.jar:/opt/jdk1.6.0/jre/lib/jce.jar:/opt/jdk1.6.0/jre/lib/charsets.jar:/opt/jdk1.6.0/jre/classes
>     2010-08-20 15:51:45,186 INFO  [Log4jService]
>     ----------------------------------------------
>     2010-08-20 15:51:45,193 ERROR [GBeanInstanceState] Error while
>     starting; GBean is now in the FAILED state:
>     abstractName="org.apache.geronimo.framework/j2ee-system/2.2/car?ServiceModule=org.apache.geronimo.framework/j2ee-system/2.2/car,j2eeType=AttributeStore,name=AttributeManager"
>
>
>     java.lang.NoClassDefFoundError: Could not initialize class
>     org.apache.geronimo.system.configuration.AttributesXmlUtil
>         at
>     org.apache.geronimo.system.configuration.LocalAttributeManager.read(LocalAttributeManager.java:373)
>         at
>     org.apache.geronimo.system.configuration.LocalAttributeManager.load(LocalAttributeManager.java:354)
>         at
>     org.apache.geronimo.system.configuration.LocalAttributeManager.doStart(LocalAttributeManager.java:547)
>         at
>     org.apache.geronimo.gbean.runtime.GBeanInstance.createInstance(GBeanInstance.java:953)
>         at
>     org.apache.geronimo.gbean.runtime.GBeanInstanceState.attemptFullStart(GBeanInstanceState.java:269)
>         at
>     org.apache.geronimo.gbean.runtime.GBeanInstanceState.start(GBeanInstanceState.java:103)
>         at
>     org.apache.geronimo.gbean.runtime.GBeanInstanceState.startRecursive(GBeanInstanceState.java:125)
>         at
>     org.apache.geronimo.gbean.runtime.GBeanInstance.startRecursive(GBeanInstance.java:539)
>         at
>     org.apache.geronimo.kernel.basic.BasicKernel.startRecursiveGBean(BasicKernel.java:377)
>         at
>     org.apache.geronimo.kernel.config.ConfigurationUtil.startConfigurationGBeans(ConfigurationUtil.java:456)
>         at
>     org.apache.geronimo.kernel.config.ConfigurationUtil.loadBootstrapConfiguration(ConfigurationUtil.java:208)
>         at
>     org.apache.geronimo.kernel.config.ConfigurationUtil.loadBootstrapConfiguration(ConfigurationUtil.java:167)
>         at
>     org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.loadBootConfiguration(MainConfigurationBootstrapper.java:84)
>         at
>     org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.getMain(MainConfigurationBootstrapper.java:57)
>         at
>     org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:38)
>         at
>     org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
>         at
>     org.apache.geronimo.cli.daemon.DaemonCLI.main(DaemonCLI.java:30)
>     2010-08-20 15:51:45,195 INFO  [Log4jService] Stopping Logging Service
>     2010-08-20 15:51:45,195 INFO  [Log4jService]
>     ----------------------------------------------
>
>
>     Regards,
>     Shailen (khichi.shailendra@gmail.com  <mailto:khichi.shailendra@gmail.com>)
>     +91-9216020360
>     Mohali, Chandigarh - 160062
>
>
>     On Friday 20 August 2010 02:27 PM, Ivan wrote:
>>     Could you check that what is the actual JRE version in the log
>>     file var/log/geronimo.log ?
>>     There should something like :
>>     INFO  [Log4jService]   JVM in use        = ****
>>
>>     From the exception message, it seems that it is caused by JRE
>>     loads an old jaxb 2.0 api.
>>     One solution is to upgrade the JRE on that machine, another
>>     solution is to download the jaxb 2.1 api package and place it in
>>     the endorsed directory, which is suggested by the exception message.
>>
>>     2010/8/20 Shailen <khichi.shailendra@gmail.com
>>     <mailto:khichi.shailendra@gmail.com>>
>>
>>         I am also successful with jdk 1..6.0_13 on my personal machine.
>>         Not able to figure out the problem with this machine.
>>         Between checking with my jdk on this machine.
>>
>>
>>         Regards,
>>         Shailen (khichi.shailendra@gmail.com  <mailto:khichi.shailendra@gmail.com>)
>>         +91-9216020360
>>         Mohali, Chandigarh - 160062
>>
>>
>>         On Friday 20 August 2010 01:50 PM, Forrest Xia wrote:
>>>         I can run g 2.2 on my ubuntu with sun jdk 1.6.0_20, can you
>>>         have a try with that?
>>>
>>>         Forrest
>>
>>
>>
>>
>>     -- 
>>     Ivan
>
>
>
>
> -- 
> Ivan

Mime
View raw message