geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Billy Vandory <>
Subject Re: Geronimo 2.2 + Spring + Hibernate and a Geronimo managed DB Pool with XA driver
Date Fri, 16 Jul 2010 01:43:52 GMT

I'm still having a problem with this.  I've determined it's not spring, it's
most likely just a configuration issue.  The problem is trying to get a
lookup to a global database pool in geronimo.  In an SL-EJB I have:

InitialContext ctx = new InitialContext();
DataSource ds = (DataSource) ctx.lookup("java:comp/env/jdbc/testmydb");
Connection con = ds.getConnection();

and my deployment plan for the db looks like (copied from geronimo's show
plan button):

<connector xmlns="">
                    <config-property-setting name="PrepareThreshold"/>

but i always get the exception:

80041:  2010-07-15 21:30:06,442 ERROR [CategoryEJB]
javax.naming.NotContextException: jdbc/testmydb

Note that I am not running a web app, just an EJB backend, so I am not
configuring anything in web.xml.  is the configuration in web.xml required? 
I tried it and its the same result, but I would like to rule this out, that
web.xml resource-ref config is not required if not running in a web app.

The JNDI name under geronimo's JNDI viewer is: (resource adapters)

also shows:

In the geronimo deployment plan i have a connector defined:


Using dbpool in the geronimo console, i can query this database just fine.'

Any ideas?  Thanks alot.

View this message in context:
Sent from the Users mailing list archive at

View raw message