geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Startup fails for geronimo 2.2 when using a symbolic link for startup.sh
Date Tue, 08 Jun 2010 13:17:43 GMT

On Jun 4, 2010, at 11:52 AM, Sarah Brake wrote:

> 
> 
> I'm trying to startup a geronimo 2.2 server using a symlink for startup.sh, but the server
does not start up successfully.  We use this same setup for version 2.1.4 and do not have
these problems.
> 
> I have geronimo 2.2 installed on a device at /opt/geronimo-jetty7-javaee5-2.2.
> 
> I created a symlink to this directory using the following command:
> $ ln -s /opt/geronimo-jetty7-javaee5-2.2/ current
> 
> I then created a symlink to startup.sh:
> $ ln -s current/bin/startup.sh startup.sh
> 
> If I run 
> $ ./startup.sh
> 
> the server fails to start up, having problems with starting console-jetty.  A partial
trace is located below.
> 
> If I run the startup.sh command directly from the /opt/geronimo-jetty7-javaee5-2.2/bin
directory, the server starts up without error.

I don't really know why this worked on 2.1.4 and now doesn't work on 2.2. Pretty sure the
problem is related to your GERONIMO_HOME setting. I don't think GERONIMO_HOME is being set
differently. More that Geronimo 2.2 is probably more sensitive...

Starting geronimo 2.2 normally:

Using GERONIMO_HOME:   /home/kevan/geronimo-tomcat6-javaee5-2.2
Using GERONIMO_TMPDIR: var/temp
...

Starting geronimo 2.2 with your symbolic links:

Using GERONIMO_HOME:   /home/kevan/current/
Using GERONIMO_TMPDIR: var/temp
...

If I set GERONIMO_HOME=/home/kevan/geronimo-tomcat6-javaee2.2 and run with the symbolic links,
the server starts correctly. 

--kevan
Mime
View raw message