geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: deploying grails to geromino xml problem for web app in
Date Tue, 04 May 2010 06:23:06 GMT
<environment>

  xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">

is wrong.

I like to use an xml editor that shows me stupid syntax typos like this -- I certainly type
them frequently.  I use IDEA community edition which is free.

thanks
david jencks
On May 3, 2010, at 10:56 PM, Tapas Mishra wrote:

> 
> I am a newbie to xml,geromino and grails
> when I am trying to deploy my war application
> I am getting following error.
> 
> 
> 2010-05-03 23:42:49,082 ERROR [DeployTool] Error: 
> org.apache.geronimo.common.DeploymentException: Unable to deploy
> a12-0.1.war: xml problem for web app .
> 	Invalid deployment descriptor: errors:
> 
> error: Can't have mixed content
> 
> error: cvc-complex-type.2.3: Element
> 'environment@http://geronimo.apache.org/xml/ns/deployment-1.2' with
> element-only content type cannot have text content.
> 
> Descriptor:
> <xml-fragment xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
> xmlns:jet="http://geronimo.apache.org/xml/ns/j2ee/web/jetty-2.0.2">
>  xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1"
>   xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.1"
>   xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.1"
>   xmlns:security="http://geronimo.apache.org/xml/ns/security-1.1">
>  <dep:environment>
>    xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
>    <dep:moduleId>
>      <dep:groupId>geronimo</dep:groupId>
>      <dep:artifactId>a12</dep:artifactId>
>      <dep:version>1.1</dep:version>
>      <dep:type>war</dep:type>
>    </dep:moduleId>
>  </dep:environment>
>  <jet:context-root>/a12</jet:context-root>
> </xml-fragment>
> 
> 
> 	at
> org.apache.geronimo.deployment.cli.CommandDeploy.runCommand(CommandDeploy.java:45)
> 	at
> org.apache.geronimo.deployment.cli.CommandDistribute.executeOnline(CommandDistribute.java:149)
> 	at
> org.apache.geronimo.deployment.cli.CommandDistribute.execute(CommandDistribute.java:125)
> 	at
> org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java:168)
> 	at
> org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:45)
> 	at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:65)
> 	at org.apache.geronimo.cli.deployer.DeployerCLI.main(DeployerCLI.java:31)
> 
> 
> 
> 
> Content of my geronimo-web.xml file are 
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
> 
>   xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1"
>   xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.1"
>   xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.1"
>   xmlns:security="http://geronimo.apache.org/xml/ns/security-1.1">
> <environment>
> 
>   xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
>   <moduleId><groupId>geronimo</groupId>
>   <artifactId>a12</artifactId>
>   <version>1.1</version><type>war</type>
>   </moduleId>
> </environment>
> <context-root>/a12</context-root>
> 
> </web-app>
> 
> What is wrong in above xml or if it is right then what is the cause of the
> error?
> -- 
> View this message in context: http://apache-geronimo.328035.n3.nabble.com/deploying-grails-to-geromino-xml-problem-for-web-app-in-tp775201p775201.html
> Sent from the Users mailing list archive at Nabble.com.


Mime
View raw message