geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ttiurani <timo.tiurani...@iki.fi>
Subject Re: issue deploying webapp with security realm
Date Mon, 24 May 2010 08:54:39 GMT

Hi,

I am getting the same error with geronimo 2.2, but there does not seem to be
any way around my problem. I am trying to deploy my application with one
.ear-file and use a custom security realm that is created with
geronimo-application.xml and referenced in geronimo-web.xml. This does not
seem to be possible anymore with Geronimo 2.2.

geronimo-application.xml has this:

       <dep:gbean name="MySecurityRealmGBean"
		class="org.apache.geronimo.security.realm.GenericSecurityRealm"
		xsi:type="dep:gbeanType"
		xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
		xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
		<dep:attribute name="realmName">MySecurityRealm</dep:attribute>
		<dep:reference name="ServerInfo">
			<dep:name>ServerInfo</dep:name>
		</dep:reference>
		<dep:xml-reference name="LoginModuleConfiguration">
			<log:login-config
xmlns:log="http://geronimo.apache.org/xml/ns/loginconfig-2.0">
				<log:login-module control-flag="REQUIRED"
					wrap-principals="false">
					<log:login-domain-name>
						MySecurityRealm
					</log:login-domain-name>
					<log:login-module-class>
                                         org.test.MySecurityRealmLoginModule
					</log:login-module-class>
				</log:login-module>
			</log:login-config>
		</dep:xml-reference>
	</dep:gbean>

and geronimo-web.xml inside the same .ear tries to reference the realm with
this:

        <security-realm-name>MySecurityRealm</security-realm-name>

Now this has worked nicely with Geronimo 2.0.1 -> 2.1.3 (I'm guessing it
works for 2.1.4 and 2.1.5 as well) but it fails with 2.2 with the same stack
trace as in the first message. I'm guessing the problem is this that by the
time geronimo-web.xml is evaluated during deployment, the custom security
realm from geronimo-application.xml is not either created yet or then there
is some kind of class loader problem.

I've tried every kind of combination of geronimo-application.xml and
geronimo-web.xml and am quite confident the problem is not a simple
configuration typo or lack of <depencency> tags.

I believe it is possible to do this in two separete deployments, where I
would first deploy the custom security realm alone to Geronimo and then
reference it in a separeate .ear containing a geronimo-web.xml with a
dependency to something like this:

       <dependency>
              <groupId>org.test</groupId>
              <artifactId>security</artifactId>
              <version>1.0</version>
              <type>car</type>
        </dependency>

The unfortunate thing is, this approach complicates my development so
significantly, it is out of the question.

Is it possible to create and reference a custom login module inside a single
.ear with Geronimo 2.2? If not, is this possiblity removed from 2.2 on
purpose, or is it a bug that wil be fixed in later versions?

Best regards,
Timo Tiuraniemi

p.s. This seems to be possible in JBoss
(http://community.jboss.org/thread/145856).
-- 
View this message in context: http://apache-geronimo.328035.n3.nabble.com/issue-deploying-webapp-with-security-realm-tp334180p839216.html
Sent from the Users mailing list archive at Nabble.com.

Mime
View raw message