Read this: http://geronimo.apache.org/2010/02/27/jpa-20-available-for-213-and-later-server-users.html

-Jack

On Tue, Mar 2, 2010 at 5:37 PM, Michael Simons <michael.simons@optitool.de> wrote:
Hello,

Geronimo 2.2 is JEE 5 certified. JEE 5 includes JPA 1.2 (JSR 220). Unfortunately we need
features of JPA 2.0 (JSR 317).

Does Geronimo 2.2 support the JPA 2.0 spec?

Can I run Geronimo with the RI of JPA 2.0?

Kind Regards, Michael