geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Delos <dait...@gmail.com>
Subject Re: Missing JSTL TLD error in Eclipse/GEP against Geronimo v2.2
Date Mon, 29 Mar 2010 09:41:14 GMT
Thanks Bevon. I've created a JIRA and will fix it soon.

https://issues.apache.org/jira/browse/GERONIMODEVTOOLS-607

2010/3/25 Kevan Miller <kevan.miller@gmail.com>

>
> On Mar 20, 2010, at 4:23 PM, Bevon wrote:
>
> >
> > Hi,
> > I am using:
> > Eclipse v3.5.2
> > Apache GEP  v2.2.0
> > Apache Geromino v2.2
> >
> > I am migrating a Web 2.5 project from Apache Geronimo v2.1.4 to Apache
> > Geronimo v2.2.  My JSP's use a few simple JSTL tags.  After switching the
> > target runtime of my project to AG v2.2, I see the following error in the
> > Problems view:
> >
> > Can not find the tag library descriptor for
> > "http://java.sun.com/jsp/jstl/core"
> >
> > From what I can tell, the jstl jar is included in the AG v2.1.4 runtime
> > library that is added to the web project.  However, when I move to AG
> v2.2,
> > the jstl jar is no longer included in the runtime library.  The jstl jar
> > does exist in AG v2.2, but its location has moved in the repository.
> > Perhaps GEP hasn't taken this into account?  If I manually add the jstl
> jar
> > from the AG v2.2 repository as an external jar, then the error goes away.
> >
> > In any case, the JSP still runs correctly, but during dev't, I no longer
> get
> > auto-completion and I see lots of warnings re: unknown tags.
> >
> > If you have any questions about my scenario/usage, please don't hesitate
> to
> > ask.
>
> Thanks Bevon. Sounds like a problem to me... Hoping that Tim or Delos can
> chime in... If you could create a Jira, that would be great.
>
> --kevan




-- 
Best Regards,

Delos

Mime
View raw message