geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: After redeploy Application: MDB dont receive Messages
Date Mon, 29 Mar 2010 13:58:37 GMT

On Mar 29, 2010, at 5:04 AM, crashman wrote:

> 
> hello together,
> we have very often a problem after/during redeploying a ear-file.
> 
> situation: ear-file with active-mq queue and MDB and some
> stateless-session-beans.
> what we do is the following: take traffic from application, stop
> application, undeploy it, deploy the new ear-file.
> after this, sometimes we have a situation like this: the application put new
> messages into
> the queue, but the MDB don't receive it. In this moment you can see the
> messages
> in the internal db-table: APP.ACTIVEMQ_MSGS. 
> our only solution for this problem is to delete the content of the table
> APP.ACTIVEMQ_MSGS.
> stopping appliaction does not work the moment. so we shut down the server.
> setting
> the module of the application to load="false" in the config.xml, start the
> server, undeploy
> app and deploy app again. after that, everythings works fine...until the
> next update...
> but we have a downtime of server..and we have a lot of apps like this...
> 
> Do you see a failure in our doing while we update the appliaction?
> Is it possible to avoid this troubles ?

A minor note: you don't have to set load="false" on your application. While your server is
stopped you can undeploy with:

./deploy.sh --offline undeploy <module-name>

What version of Geronimo are you using? I recall someone else having a redeploy problem, but
don't recall the specifics. Any errors in your server log?

--kevan
Mime
View raw message