geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From crashman <thescha...@web.de>
Subject After redeploy Application: MDB dont receive Messages
Date Mon, 29 Mar 2010 09:04:11 GMT

hello together,
we have very often a problem after/during redeploying a ear-file.

situation: ear-file with active-mq queue and MDB and some
stateless-session-beans.
what we do is the following: take traffic from application, stop
application, undeploy it, deploy the new ear-file.
after this, sometimes we have a situation like this: the application put new
messages into
the queue, but the MDB don't receive it. In this moment you can see the
messages
in the internal db-table: APP.ACTIVEMQ_MSGS. 
our only solution for this problem is to delete the content of the table
APP.ACTIVEMQ_MSGS.
stopping appliaction does not work the moment. so we shut down the server.
setting
the module of the application to load="false" in the config.xml, start the
server, undeploy
app and deploy app again. after that, everythings works fine...until the
next update...
but we have a downtime of server..and we have a lot of apps like this...

Do you see a failure in our doing while we update the appliaction?
Is it possible to avoid this troubles ?

thanks for help.

-- 
View this message in context: http://n3.nabble.com/After-redeploy-Application-MDB-dont-receive-Messages-tp682919p682919.html
Sent from the Users mailing list archive at Nabble.com.

Mime
View raw message