geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Billy Vandory <billy_vand...@yahoo.com>
Subject Geronimo plugin issue (or maven)?
Date Fri, 26 Mar 2010 07:03:21 GMT

Geronimo plugin 2.2 for Eclipse 3.4 on Geronimo 2.2 runtime

I have a very simple project in Eclipse: 3 projects: Ear, Web and Java

When I use the Geronimo plugin to publish my app, the dependencies that I
have configured in my POM are not being included in the WAR file correctly. 
Oddly, when I build the war file using maven outside of eclipse, the
dependencies are included correctly in the WAR file.  I have three
dependencies configured for the web app as follows:

<dependency>
  <groupId>com.waka</groupId>
  <artifactId>logging</artifactId>
  <version>1.0</version>			
</dependency>	
<dependency>
  <groupId>org.apache</groupId>
  <artifactId>log4j</artifactId>
  <version>1.2.15</version>
</dependency>
<dependency>
  <groupId>org.apache.geronimo.specs</groupId>
  <artifactId>geronimo-servlet_2.5_spec</artifactId>
  <version>1.2</version>
  <scope>provided</scope>
</dependency>


Using the geronimo plugin, org.apache.log4j is being included (correct), the
com.waka.logging dependency is not being included (problem) and the
geronimo_servlet_specs is being included (it shouldnt be, since the scope is
provided)  

I have tried using the "Add a runtime dependency to Geronimo's shared
library" option, with the same result.

Just as a side note, In geronimo-web.xml, im hiding the apache log4j classes
as I want to use my own logging facility.

Has anyone else experienced this problem? 

Thanks,

Billy
-- 
View this message in context: http://n3.nabble.com/Geronimo-plugin-issue-or-maven-tp634363p634363.html
Sent from the Users mailing list archive at Nabble.com.

Mime
View raw message