geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish Jain <ashja...@gmail.com>
Subject Re: How to configure a FARM in Geronimo
Date Thu, 11 Feb 2010 11:24:00 GMT
Hi Zeros,

The logic has been modified and we no longer use the logic of creating
slave. Rather the original module name is treated as slave and we create a
master configuration by appending _G_MASTER.

Thanks
Ashish

On Fri, Feb 5, 2010 at 5:29 PM, zeros <sergio.ortega.gamero@gmail.com>wrote:

>
> Good morning:
>
>    I'm trying to configure a farm to deploy an EAR in two servers. I'm
> following the instructions given in the documentation but something is
> missing. First of all my configuration is the next one.
>
> GERONIMO1/config.xml
>
> <module name="org.apache.geronimo.configs/farming/2.2/car">
>        <gbean name="NodeInfo">
>            <attribute name="name">${ClusterNodeName}</attribute>
>        </gbean>
>        <gbean name="ClusterInfo">
>            <attribute name="name">${FarmName}</attribute>
>        </gbean>
>        <gbean
>
> name="org.apache.geronimo.configs/farming/2.2/car?ServiceModule=org.apache.geronimo.configs/farming/2.2/car,j2eeType=NodeInfo,name=NODE2"
> gbeanInfo="org.apache.geronimo.farm.config.BasicNodeInfo">
>            <attribute name="name">NODE2</attribute>
>            <attribute
>
> propertyEditor="org.apache.geronimo.farm.config.BasicExtendedJMXConnectorInfoEditor"
> name="extendedJMXConnectorInfo">
>                <ns:javabean
> class="org.apache.geronimo.farm.config.BasicExtendedJMXConnectorInfo"
> xmlns="" xmlns:ns29="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns="http://geronimo.apache.org/xml/ns/deployment/javabean-1.0"
> xmlns:ns25="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns26="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns27="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns28="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns21="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns22="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns23="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns24="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns20="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns40="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns16="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns17="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns14="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns15="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns38="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns39="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns36="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns18="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns37="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns19="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns9="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns34="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns35="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns32="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns33="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns5="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns12="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns30="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns6="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns13="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns31="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns7="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns10="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns8="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns11="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns4="http://geronimo.apache.org/xml/ns/attributes-1.2">
>                    <ns:property name="username">system</ns:property>
>                    <ns:property name="password">manager</ns:property>
>                    <ns:property name="protocol">rmi</ns:property>
>                    <ns:property name="host">192.168.30.11</ns:property>
>                    <ns:property name="port">1099</ns:property>
>                    <ns:property name="urlPath">JMXConnector</ns:property>
>                    <ns:property name="local">false</ns:property>
>                        </ns:javabean>
>            </attribute>
>        </gbean>
>    </module>
>
>
> GERONIMO2/config.xml
>
> <module name="org.apache.geronimo.configs/farming/2.2/car" load="false">
>        <gbean name="NodeInfo">
>            <attribute name="name">${ClusterNodeName}</attribute>
>        </gbean>
>        <gbean name="ClusterInfo">
>            <attribute name="name">${FarmName}</attribute>
>        </gbean>
>        <gbean
>
> name="org.apache.geronimo.configs/farming/2.2/car?ServiceModule=org.apache.geronimo.configs/farming/2.2/car,j2eeType=NodeInfo,name=NODE1"
> gbeanInfo="org.apache.geronimo.farm.config.BasicNodeInfo">
>            <attribute name="name">NODE1</attribute>
>            <attribute
>
> propertyEditor="org.apache.geronimo.farm.config.BasicExtendedJMXConnectorInfoEditor"
> name="extendedJMXConnectorInfo">
>                <ns:javabean
> class="org.apache.geronimo.farm.config.BasicExtendedJMXConnectorInfo"
> xmlns="" xmlns:ns29="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns="http://geronimo.apache.org/xml/ns/deployment/javabean-1.0"
> xmlns:ns25="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns26="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns27="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns28="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns21="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns22="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns23="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns24="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns20="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns16="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns17="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns14="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns15="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns18="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns19="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns9="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns30="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns12="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns5="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns13="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns6="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns10="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns7="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns8="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns11="http://geronimo.apache.org/xml/ns/attributes-1.2"
> xmlns:ns4="http://geronimo.apache.org/xml/ns/attributes-1.2">
>                    <ns:property name="username">system</ns:property>
>                    <ns:property name="password">manager</ns:property>
>                    <ns:property name="protocol">rmi</ns:property>
>                    <ns:property name="host">192.168.30.10</ns:property>
>                    <ns:property name="port">1099</ns:property>
>                    <ns:property name="urlPath">JMXConnector</ns:property>
>                    <ns:property name="local">false</ns:property>
>                        </ns:javabean>
>            </attribute>
>        </gbean>
>    </module>
>
> I start in both servers the farming module. When I deploy an EAR in
> 192.168.30.10 (NODE1) with the corresponding target, the *_G_MASTER
> application is correctly deployed in the master repository. The problem is
> that a *_G_SLAVE is never created neither in NODE1 nor in NODE2. I've been
> sniffing port 1099 in NODE2 to see if there was any communication from
> NODE1
> and nothing is done. I also assured that that communication is possible,
> trying to list NODE2's modules from NODE1 and effectively I can do that. I
> don't know if any configuration is missing since the logs show no error
> neither in NODE1 nor in NODE2.
>
> Could anyone help me?
>
> Thanks a lot
> --
> View this message in context:
> http://old.nabble.com/How-to-configure-a-FARM-in-Geronimo-tp27466829s134p27466829.html
> Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.
>
>

Mime
View raw message