geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Delos <dait...@gmail.com>
Subject Re: GEP 2.2 RC2 issue?
Date Fri, 22 Jan 2010 07:28:10 GMT
Hi Ted,

I tried a similar dynamic project in eclipse 3.5, but didn't reproduce your
problem.

If possible, could you provide your environment information, such as eclipse
version, jdk version? If you can create a JIRA and attach your project, that
will be more helpful.

BTW, here is the deployment plan for my project.

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<web:web-app xmlns:app="
http://geronimo.apache.org/xml/ns/j2ee/application-2.0" xmlns:client="
http://geronimo.apache.org/xml/ns/j2ee/application-client-2.0" xmlns:conn="
http://geronimo.apache.org/xml/ns/j2ee/connector-1.2" xmlns:dep="
http://geronimo.apache.org/xml/ns/deployment-1.2" xmlns:ejb="
http://openejb.apache.org/xml/ns/openejb-jar-2.2" xmlns:log="
http://geronimo.apache.org/xml/ns/loginconfig-2.0" xmlns:name="
http://geronimo.apache.org/xml/ns/naming-1.2" xmlns:pers="
http://java.sun.com/xml/ns/persistence" xmlns:pkgen="
http://openejb.apache.org/xml/ns/pkgen-2.1" xmlns:sec="
http://geronimo.apache.org/xml/ns/security-2.0" xmlns:web="
http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
    <dep:environment>
        <dep:moduleId>
            <dep:groupId>default</dep:groupId>
            <dep:artifactId>TestABC</dep:artifactId>
            <dep:version>1.0</dep:version>
            <dep:type>car</dep:type>
        </dep:moduleId>
        <dep:dependencies>
            <dep:dependency>

 <dep:groupId>org.apache.geronimo.plugins.monitoring</dep:groupId>
                <dep:artifactId>mconsole-ds</dep:artifactId>
            </dep:dependency>
            <dep:dependency>
                <dep:groupId>log4j</dep:groupId>
                <dep:artifactId>log4j</dep:artifactId>
                <dep:version>1.2.15</dep:version>
                <dep:type>jar</dep:type>
            </dep:dependency>
            <dep:dependency>
                <dep:groupId>org.apache.geronimo.configs</dep:groupId>
                <dep:artifactId>system-database</dep:artifactId>
            </dep:dependency>
            <dep:dependency>
             <dep:groupId>net.sourceforge.serp</dep:groupId>
             <dep:artifactId>serp</dep:artifactId>
             <dep:version></dep:version>
            </dep:dependency>
        </dep:dependencies>
    </dep:environment>
    <web:context-root>/TestABC</web:context-root>
    <name:resource-ref>
        <name:ref-name>jdbc/MyDataSource</name:ref-name>
        <name:pattern>

 <name:groupId>org.apache.geronimo.plugins.monitoring</name:groupId>
            <name:artifactId>mconsole-ds</name:artifactId>
            <name:name>MonitoringClientDS</name:name>
        </name:pattern>
    </name:resource-ref>
</web:web-app>


2010/1/22 Ted Kirby <ted.kirby@gmail.com>

> I have created a dynamic web project and it seems to work fine.  I can
> deploy and use the war file, and it gets republished if I change
> source.  However, on every deploy/republish, I get this error in
> eclipse:
>
> Module config Id not found for undeployment
>
> java.lang.NullPointerException
> at
> org.apache.geronimo.st.core.jaxb.JAXBUtils.unmarshalFilterDeploymentPlan(JAXBUtils.java:126)
> at
> org.apache.geronimo.st.v21.core.GeronimoV21Utils.getWebDeploymentPlan(GeronimoV21Utils.java:236)
> at
> org.apache.geronimo.st.v21.core.GeronimoV21Utils.getWebDeploymentPlan(GeronimoV21Utils.java:199)
> at
> org.apache.geronimo.st.v21.core.GeronimoV21Utils.getWebDeploymentPlan(GeronimoV21Utils.java:179)
> at
> org.apache.geronimo.st.v21.core.GeronimoV21Utils.getConfigId(GeronimoV21Utils.java:119)
> at
> org.apache.geronimo.st.v21.core.GeronimoV21VersionHandler.getConfigID(GeronimoV21VersionHandler.java:36)
> at
> org.apache.geronimo.st.core.commands.UndeployCommand.execute(UndeployCommand.java:53)
> at
> org.apache.geronimo.st.core.commands.SynchronizedDeploymentOp.run(SynchronizedDeploymentOp.java:84)
> at
> org.apache.geronimo.st.core.commands.SynchronizedDeploymentOp.execute(SynchronizedDeploymentOp.java:76)
> at
> org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.unDeploy(GeronimoServerBehaviourDelegate.java:740)
> at
> org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.doRemoved(GeronimoServerBehaviourDelegate.java:666)
> at
> org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.invokeCommand(GeronimoServerBehaviourDelegate.java:451)
> at
> org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.publishModule(GeronimoServerBehaviourDelegate.java:318)
> at
> org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModule(ServerBehaviourDelegate.java:948)
> at
> org.apache.geronimo.st.core.GeronimoServerBehaviourDelegate.publishModules(GeronimoServerBehaviourDelegate.java:273)
> at
> org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:872)
> at
> org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:708)
> at
> org.eclipse.wst.server.core.internal.Server.publishImpl(Server.java:2690)
> at
> org.eclipse.wst.server.core.internal.Server$PublishJob.run(Server.java:272)
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
>
> If I export the project as a war file, and deploy it to geronimo, I
> don't get the error, so I suspect it's a GEP problem.
>
> Here is my geronimo-web.xml file:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <web:web-app xmlns:app="
> http://geronimo.apache.org/xml/ns/j2ee/application-2.0"
>        xmlns:client="
> http://geronimo.apache.org/xml/ns/j2ee/application-client-2.0"
>        xmlns:conn="http://geronimo.apache.org/xml/ns/j2ee/connector-1.2"
>        xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2"
> xmlns:ejb="http://openejb.apache.org/xml/ns/openejb-jar-2.2"
>        xmlns:log="http://geronimo.apache.org/xml/ns/loginconfig-2.0"
>        xmlns:name="http://geronimo.apache.org/xml/ns/naming-1.2"
> xmlns:pers="http://java.sun.com/xml/ns/persistence"
>        xmlns:pkgen="http://openejb.apache.org/xml/ns/pkgen-2.1"
> xmlns:sec="http://geronimo.apache.org/xml/ns/security-2.0"
>        xmlns:web="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1">
>        <dep:environment>
>                <dep:moduleId>
>
>  <dep:groupId>com.ibm.websphere.xs.sample</dep:groupId>
>                        <dep:artifactId>GettnStarted3</dep:artifactId>
>                        <dep:version>1.0</dep:version>
>                        <dep:type>jar</dep:type>
>                </dep:moduleId>
>                <dep:dependencies>
>                        <dep:dependency>
>
>  <dep:groupId>com.ibm.websphere.xs</dep:groupId>
>                                <dep:artifactId>ogclient</dep:artifactId>
>                                <dep:version>7.0</dep:version>
>                                <dep:type>jar</dep:type>
>                        </dep:dependency>
>                        <dep:dependency>
>
>  <dep:groupId>com.ibm.websphere.xs</dep:groupId>
>                                <dep:artifactId>objectgrid</dep:artifactId>
>                                <dep:version>7.0</dep:version>
>                                <dep:type>jar</dep:type>
>                        </dep:dependency>
>                        <dep:dependency>
>
>  <dep:groupId>org.apache.geronimo.configs</dep:groupId>
>
>  <dep:artifactId>system-database</dep:artifactId>
>                        </dep:dependency>
>                </dep:dependencies>
>        </dep:environment>
>        <web:context-root>/GetnStarted3AG</web:context-root>
>        <name:resource-ref>
>                <name:ref-name>jdbc/CRUD_DS</name:ref-name>
>                <name:resource-link>SystemDatasource</name:resource-link>
>        </name:resource-ref>
> </web:web-app>
>



-- 
Best Regards,

Delos

Mime
View raw message