geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Russell Collins <Russell.Coll...@mclaneat.com>
Subject RE: Geronimo 2.2 GEP [Resolution]
Date Wed, 06 Jan 2010 14:42:54 GMT
Thank you for your help.  Here is how the problem was solved and I hope this helps someone
in a similar situation.


1.    The first thing I did was upgrade from Eclipse Ganymede to Galileo.  When I did this,
the 2.1.x GEP did not install.

2.    I found that some people were getting around this issue by installing the WASCE plug-in.
 This worked.  I was able to use Geronimo 2.1.4 as I was before on Eclipse Ganymede.

3.    Geronimo 2.2 is released and the GEP tool is available (not released).  I try to install
various versions of the software.  No success.  The main error I keep getting is that the
2.2 adapter cannot be installed since the WASCE adapter is in there.

4.    I try to install and remove every trace of WASCE.  No success.  I get the same error.

5.    I get a fresh copy of Eclipse Galileo and it installs without a problem.

Observations: WASCE does not uninstall cleanly.  GEP 2.2 does not know how to get around an
installation that has/had WASCE installed.  I don't know if this is something that is fixable
on the Eclipse side or Apache side (or IBM side).  Bottom line, they do not play well together
(probably more so WASCE takes control and does not let go) so be careful.

From: Delos [mailto:daition@gmail.com]
Sent: Tuesday, January 05, 2010 7:54 PM
To: user@geronimo.apache.org
Subject: Re: Geronimo 2.2 GEP

No need to install core feature with adapter 2.2. Just select adapter 2.2 to install it.

2010/1/5 Russell Collins <Russell.Collins@mclaneat.com<mailto:Russell.Collins@mclaneat.com>>
Ok.  I switched up the site.  I try to get the Geronimo Core 2.1.1 and Geronimo Adapter 2.2.
 I get the following error:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Geronimo Core Feature 2.1.1 (org.apache.geronimo.feature.feature.group
2.1.1)
  Missing requirement: Geronimo Core Feature 2.1.1 (org.apache.geronimo.feature.feature.group
2.1.1) requires 'org.eclipse.jst.feature.group [2.0.0,3.0.0)' but it could not be found


I am using Eclipse Galileo.  I have tried updating with as many jst features as I can get
on Eclipse through their update site.  How can I correct this error?  Do I need to install
the core feature with adapter 2.2?

From: Delos [mailto:daition@gmail.com<mailto:daition@gmail.com>]
Sent: Monday, January 04, 2010 7:46 PM
To: user@geronimo.apache.org<mailto:user@geronimo.apache.org>
Subject: Re: Geronimo 2.2 GEP

Hi Russell,

I'm sorry to tell you that the package at http://people.apache.org/dist/geronimo/eclipse/unstable/updates
is out of date.

Due to authorization problem, I can't update the packages there. Currently, you can try the
site here:
http://people.apache.org/dist/geronimo/eclipse/2.2.0/RC1/staging_site/updates/
2010/1/5 Russell Collins <Russell.Collins@mclaneat.com<mailto:Russell.Collins@mclaneat.com>>
I am trying to install the Eclipse plug-in for Geronimo 2.2.  I am using this site:

http://people.apache.org/dist/geronimo/eclipse/unstable/updates

When it try to perform the update, I am getting this error:

    Cannot complete the install because of a conflicting dependency.
      Software being installed: Geronimo v2.2 Server Adapter 2.2.0 (org.apache.geronimo.v22.feature.feature.group
2.2.0)
      Software currently installed: WASCE v2.1 Server Adapter 2.1.4 (com.ibm.wasce.v21.feature.feature.group
2.1.4)
      Only one of the following can be installed at once:
        Geronimo V20 Runtime Plug-in 2.1.4 (org.apache.geronimo.runtime.v20 2.1.4)
        org.apache.geronimo.runtime.v20 2.1.3
      Cannot satisfy dependency:
        From: WASCE v2.1 Server Adapter 2.1.4 (com.ibm.wasce.v21.feature.feature.group 2.1.4)
        To: org.apache.geronimo.runtime.v20 [2.1.4]
      Cannot satisfy dependency:
        From: Geronimo v2.2 Server Adapter 2.2.0 (org.apache.geronimo.v22.feature.feature.group
2.2.0)
    To: org.apache.geronimo.runtime.v20 [2.2.0]


I cleaned everything related to previous Geronimo and WASCE adapters so I do not know why
I am getting this.  Also, I have tried to manually update the my plug-in and features folder
with no success.  I am using Eclipse Galileo.  Any suggestions would be greatly appreciated.



Russell Collins
Sr. Software Engineer
McLane Advanced Technology
254.771.6419



________________________________
CONFIDENTIALITY NOTICE: The information contained in this electronic mail (email) transmission
(including attachments), is intended by MCLANE ADVANCED TECHNOLOGIES for the use of the named
individual or entity to which it is addressed and may contain information that is privileged,
confidential and/or protected as a trade secret. It is not intended for transmission to, or
receipt by, any individual or entity other than the named addressee(s). If you have received
this email in error, please delete it (including attachments) and any copies thereof without
printing, copying or forwarding it, and notify the sender of the error by email reply immediately.



--
Best Regards,

Delos

________________________________
CONFIDENTIALITY NOTICE: The information contained in this electronic mail (email) transmission
(including attachments), is intended by MCLANE ADVANCED TECHNOLOGIES for the use of the named
individual or entity to which it is addressed and may contain information that is privileged,
confidential and/or protected as a trade secret. It is not intended for transmission to, or
receipt by, any individual or entity other than the named addressee(s). If you have received
this email in error, please delete it (including attachments) and any copies thereof without
printing, copying or forwarding it, and notify the sender of the error by email reply immediately.



--
Best Regards,

Delos

________________________________
CONFIDENTIALITY NOTICE: The information contained in this electronic mail (email) transmission
(including attachments), is intended by MCLANE ADVANCED TECHNOLOGIES for the use of the named
individual or entity to which it is addressed and may contain information that is privileged,
confidential and/or protected as a trade secret. It is not intended for transmission to, or
receipt by, any individual or entity other than the named addressee(s). If you have received
this email in error, please delete it (including attachments) and any copies thereof without
printing, copying or forwarding it, and notify the sender of the error by email reply immediately.

Mime
View raw message