geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Brown <wbr...@colorfulsoftware.com>
Subject Re: issue deploying webapp with security realm
Date Mon, 11 Jan 2010 21:29:01 GMT


Bill Brown wrote:
> 
> According to the reports, I should be able to work around the issue by
> adding the security realm as a dependency in the geronimo-web.xml. 
> https://issues.apache.org/jira/browse/GERONIMO-4553?focusedCommentId=12738770&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_12738770
> 

Ok. I answered the question after a little while of trial and error.  I
needed to replace these in geronimo-web.xml <environment> section:

                        <dep:dependency>
				<dep:groupId>org.apache.geronimo.configs</dep:groupId>
				<dep:artifactId>j2ee-server</dep:artifactId>
				<dep:type>car</dep:type>
			</dep:dependency>
			<dep:dependency>
				<dep:groupId>org.apache.geronimo.framework</dep:groupId>
				<dep:artifactId>j2ee-security</dep:artifactId>
				<dep:version>2.2</dep:version>
				<dep:type>car</dep:type>
			</dep:dependency>

			<dep:dependency>
				<dep:groupId>org.apache.geronimo.framework</dep:groupId>
				<dep:artifactId>j2ee-security</dep:artifactId>
				<dep:type>car</dep:type>
			</dep:dependency>
			
With this one which is found in the usage section for the realm listing in
the console repository.

			<dependency>
                              <groupId>console.realm</groupId>
                              <artifactId>feedwork</artifactId>
                              <version>1.0</version>
                              <type>car</type>
                        </dependency> 

And the app deployed just fine with the authentication/authorization
working. 
HTH. 

Bill. 
-- 
View this message in context: http://old.nabble.com/issue-deploying-webapp-with-security-realm-tp27112307s134p27118057.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message