geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miroslav Beranič ml. <miroslav.bera...@mibesis.si>
Subject Re: Internal error in the plugin manager getting plugin 'org.codehaus.mojo.jspc:jspc-maven-plugin'
Date Fri, 25 Dec 2009 13:19:07 GMT
Hi,

I managed to build all the code (Apache Geronimo 2.1.4) and samples in
SVN:/branches/2.1

The documentation is slightly incorrect. It is written: use Maven
2.0.9 or newer, well ... it does not work with newer version. It needs
to be 2.0.9 exactly.


@Ivan: Thanks a lot.
I have more problems now with deploying sample application on Geronimo
- but this is for another thread.

Best regards,
Miroslav



2009/12/25 Miroslav Beranič ml. <miroslav.beranic@mibesis.si>:
> Ivan,
>
> I am speechless ... It works.
> Before I wrote mail, I tested it with Maven 2.1.0 and I thought, this
> is minor change... It seems like I was wrong.
>
> Now I have to build the whole thing ... the game is not over jet :)
>
>
> Thanks,
> Miroslav
>
>
>
> 2009/12/25 Ivan <xhhsld@gmail.com>:
>> Could you please try to use maven 2.0.9 and JDK 1.5 for it ?
>>
>> 2009/12/25 Miroslav Beranič ml. <miroslav.beranic@mibesis.si>
>>>
>>> Hi,
>>>
>>> I have downloaded Apache Geronimo 2.1.4-src.
>>>
>>> In unpacked root directory I have run maven clean:
>>>
>>> > cd geronimo-2.1.4-src
>>> > mvn clean
>>>
>>> I get error in build process:
>>>
>>>
>>> [INFO] Building Geronimo Plugins, ActiveMQ :: Portlets
>>> [INFO]    task-segment: [clean]
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] Internal error in the plugin manager getting plugin
>>> 'org.codehaus.mojo.jspc:jspc-maven-plugin': Plugin
>>> 'org.codehaus.mojo.jspc:jspc-maven-plugin:2.0-alpha-1-20070806' has an
>>> invalid descriptor:
>>> 1) Plugin's descriptor contains the wrong version: 2.0-alpha-1-SNAPSHOT
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] For more information, run Maven with the -e switch
>>> [INFO]
>>> ------------------------------------------------------------------------
>>>
>>>
>>>
>>> Any idea why?
>>>
>>>
>>>
>>> > mvn -version
>>> Apache Maven version:
>>> Apache Maven 2.2.1 (r801777; 2009-08-06 21:16:01+0200)
>>> Java version: 1.6.0_0
>>> Java home: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre
>>> Default locale: sl_SI, platform encoding: UTF-8
>>> OS name: "linux" version: "2.6.30.9-102.fc11.x86_64" arch: "amd64"
>>> Family: "unix"
>>>
>>>
>>>
>>> Best regards,
>>> --
>>> Miroslav Beranič ml.
>>
>>
>>
>> --
>> Ivan
>>
>

Mime
View raw message