Hi Antonio,

I looked the G doc and downloaded the file "jms-mdb-ear-2.1.2.ear" from maven repository as you did, and got the same problem as you. However, I have found the solution and made the sample work.

First, the structure of the file "jms-mdb-ear-2.1.2.ear" that worked for me is as below:

|-jms-mdb-ear-{version}.ear
†† |- META-INF
†††††† |- application.xml
†††††† |- geronimo-application.xml
†† |- geronimo-activemq-ra-{geronimoVersion}.rar
†††††† |- activemq-core-{version}.jar
†††††† |- activemq-ra-{version}.jar
†††††† |- META -INF
†††††††††† |- ra.xml
†† |- jms-mdb-ejb-{version}.jar
†††††† |- classes
†††††† |- META -INF
†††††††††† |- openejb-jar.xml
†† |- jms-mdb-war-{version}.war
†††††† |- index.jsp
†††††† |- error.jsp
†††††† |- WEB-INF
†††††††††† |- web.xml
†††††††††† |- classes
†† |- jms-resources.xml

All the .xml files mentioned above are needed. For the correct contents of "geronimo-application.xml", "openejb-jar.xml", "web.xml", and "jms-resources.xml", please download the sample applications from http://www.ibm.com/developerworks/downloads/ws/wasce/?S_TACT=105AGX01&S_CMP=LP and refer to the corresponding .xml files in the "jms-mdb" sample application. I added the .xml files in the sample application directly to my "jms-mdb-ear-2.1.2.ear" file and it worked for me.

When you compress all the files with the correct contents in the struture mention above, it should work for you. If there is still problems, please let us know.

About the Geronimo document of the jms-mdb sample, we will revise it accordingly. Thank you!

Ellen

2009/11/3 Antonio Forniť <sitaronocturnal@gmail.com>

Thank you very much. I'll try with those samples I've just downloaded.

And about the samples from geronimo docs, I've just downloaded the file
"jms-mdb-ear-2.1.2.ear" from maven repository and try to deploy it from the
console... I had the same problem!!

Deployment failed:
A connector module must be deployed using a Geronimo deployment plan (either
META-INF/geronimo-ra.xml in the RAR file or a standalone deployment plan
passed to the deployer).

How can it be the sample in the doc is not working? That's what I meant when
I said Geronimo was a "little" hard at the beginning... Thank you!
--
View this message in context: http://old.nabble.com/Trying-to-set-up-a-MDB-tp26137988s134p26158715.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.