geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Problem deploying an EAR
Date Wed, 14 Oct 2009 22:26:34 GMT
That doesn't look like a valid manifest entry for Class-Path... how is  
it generated?

thanks
david jencks

On Oct 14, 2009, at 2:03 AM, Massimiliano Ziccardi wrote:

> Hi all.
>
> I've some problem deploying on Geronumo an EAR that works beautifully
> with jBoss.
>
> The EAR is composed this way:
> EAR
>   - UTILITY1.jar
>   - UTILITY2.jar
>   - UTILITY3.jar
>   - WEBMODULE.war
>
> The WEBMODULE.war classpath configured inside the WEBMODULE.war
> manifes points to the UTILITY jar files with a row like the following:
>
> Manifest-Version: 1.0
> Built-By: nandana
> Build-Jdk: 1.5.0_08
> Class-Path: UTILITY1.jar
> UTILITY2.jar
> UTILITY3.jar
> Created-By: Apache Maven
> Archiver-Version: Plexus Archiver
>
> The whole EAR is created by Eclipse (the utility projects are simple
> Java Projects, added to J2EE module dependencies of EAR and configured
> as dependencies for the WAR file).
>
> Geronimo keep on complaining that the manifest is not correct, with a
> message like the following:
>
>  org.apache.geronimo.common.DeploymentException: Manifest class path
> entries must be a valid jar file, or if it is a directory, all the
> files with jar suffix in it must be a valid jar file (JAVAEE 5 Section
> 8.2):  resolved to targetURI= UTILITY1.jar
>
> Have you any idea?
>
> Thanks,
> Massimiliano


Mime
View raw message