geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bohn <joe.b...@earthlink.net>
Subject Re: Difficulty deploying Grails war file to Geronimo
Date Mon, 28 Sep 2009 02:24:34 GMT

Hi Ken,

Glad you figured it out.  I had played with this a while ago and 
discovered much something similar.  At the time I think I discovered 
that I could deploy into a Jetty JavaEE assembly by identifying only the 
springframework classes as hidden and in a JavaEE Tomcat assembly with 
just the jaxen classes as hidden.

One more thing to consider is that you should be able to deploy a Grails 
war into either the Jetty or Tomcat minimal Geronimo assemblies without 
any hidden-class entries at all (at least this worked about a year ago - 
probably on 2.1.3).  This might be a good solution if you don't need the 
additional capabilities in the JavaEE certified assemblies.

Joe


Ken T. wrote:
> On Sun, 27 Sep 2009 18:46:21 +0000, Ken T. wrote:
> 
>> On Sun, 27 Sep 2009 03:53:43 +0000, Ken T. wrote:
>>
>>> I'm trying to deploy a working (but very simple) grails application war
>>> to Geronimo, but with no luck.  I've already made the changes to the
>>> geronimo-web.xml file that were specified online, leaving me this:
>> This is actually getting really strange.  Once I try to install the war
>> file and then when it fails go to Web App Wars and try to start it
>> again, I'm no longer able to view my installed Web Apps.  The war breaks
>> Geronimo.
>>
>> This really shouldn't happen, so I tried installing the latest and
>> greatest Geronimo and I'm having exactly the same problem.
> 
> I've figured out my problem.  The necessary entries in the geronimo-
> web.xml file have changed over time.  
> 
> Thank you for looking into it.  
> 
> For anyone looking for the same information, for 2.1.4 looks something 
> like this:
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
>     <environment xmlns="http://geronimo.apache.org/xml/ns/deployment-1.1">
>         <moduleId>
>             <groupId>grailsApp</groupId>
>             <artifactId>TimeTracker</artifactId>
>             <version>0.1</version>
>             <type>war</type>
>         </moduleId>
>         <hidden-classes>
>             <filter>org.springframework</filter>
>             <filter>org.apache.cxf</filter>
>             <filter>org.apache.commons</filter>
>         </hidden-classes>        
>     </environment>
>     <context-root>/TimeTracker</context-root>
>     <!-- Only if you are using virtual hosting under jetty -->
>     <virtual-host>www.mydomain.com</virtual-host>
> </web-app>
> 
> 
> 
> 
> 


Mime
View raw message