geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Ruggles <a.rugg...@gmail.com>
Subject Tomcat WADI under heaving load fails
Date Tue, 01 Sep 2009 22:11:42 GMT

I recently begin enabling WADI clustering in our test environment with two
Apache Geronimo Nodes behind a load balancer.  My current setup does not
have sticky sessions enabled.  It seems to be working well until I start
throwing a large load at the nodes.  I start receiving the following errors:

2009-09-01 15:05:03,415 INFO  [JkCoyoteHandler] Error servicing request R(
/login.action)
org.codehaus.wadi.replication.manager.ReplicationKeyNotFoundException: Key
[F78530ECFF88F89F042C8590E68E59DE] does not exist
	at
org.codehaus.wadi.replication.manager.basic.SyncReplicationManager.update(SyncReplicationManager.java:147)
	at
org.codehaus.wadi.core.session.AbstractReplicableSession.onEndProcessing(AbstractReplicableSession.java:49)
	at
org.codehaus.wadi.core.session.AtomicallyReplicableSession.onEndProcessing(AtomicallyReplicableSession.java:58)
	at
org.apache.geronimo.clustering.wadi.WADISessionAdaptor.onEndAccess(WADISessionAdaptor.java:63)
	at
org.apache.geronimo.tomcat.cluster.ClusteredManager$ClusteredSession.endAccess(ClusteredManager.java:127)
	at org.apache.catalina.connector.Request.recycle(Request.java:419)
	at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:322)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)
	at
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697)
	at
org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889)
	at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:637)


Even after the heaving activity is over the nodes are unable to recover.  I
have to restart both geronimo nodes before the cluster functions correctly
again.  Has anyone else run into this and if have you resolved it?
-- 
View this message in context: http://www.nabble.com/Tomcat-WADI-under-heaving-load-fails-tp25247803s134p25247803.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message