On Jul 22, 2009, at 1:15 PM, rpalm01@gmail.com wrote:

I'm having an issue with Axis from the version of Geronimo I downloaded last night (7.21.9): geronimo-tomcat6-javaee5-2.1.4.

Apparently there was a bug fixed in April of 2007 that I'm not getting the 1.4 version that is included in this Geronimo release.

https://issues.apache.org/jira/browse/AXIS2-2313

Does anyone have any thought on how I can determine whether the axis-1.4.jar file has this fix included in it?

Geronimo 2.1.4 uses Axis 1.3, not 1.4. It does look like the fix from AXIS2-2323 is included. The fix revision number referenced in the Jira is 528269 (note that this is from the "Subversion Commits" tab. The revision number referenced in the comments is a typo (i.e. 428269).

svn praise https://svn.apache.org/repos/asf/webservices/axis2/tags/java/v1.3/modules/jaxws/src/org/apache/axis2/jaxws/marshaller/impl/alt/MethodMarshallerUtils.java

Shows that the change did make it into the Axis2 1.3 release.

FYI, Geronimo 2.2, which will be released soon, is using Axis2 1.5.

--kevan