geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vojdan_ <vojdan_karda...@yahoo.com>
Subject Re: Standalone deployment <cross-context> doesn't work
Date Fri, 24 Jul 2009 14:34:22 GMT

Thanks for the ideas guys but I'm not that experienced with unix.
The thing is that the final environment is going to be unix, but hte
development is run under windows xp so i have a unix server available but I
don't know nothing but the basic commands.

Anyway, i did a workaround for my problem (having the strings harcoded
instead of getting them from a function in the utility project) and got hung
up somewhere else.
This is the new stacktrace:
2009-07-24 16:18:45,145 ERROR [[ReferralPatientSearchForm]]
Servlet.service() for servlet ReferralPatientSearchForm threw exception
java.lang.ClassNotFoundException: javax.wsdl.OperationType in classloader
default/ZBCEar/1.0/car
        at
org.apache.geronimo.kernel.config.MultiParentClassLoader.loadOptimizedClass(MultiParentClassLoader.java:438)
        at
org.apache.geronimo.kernel.config.MultiParentClassLoader.loadClass(MultiParentClassLoader.java:280)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)
        at
org.apache.axis.description.OperationDesc.<clinit>(OperationDesc.java:59)
        at
nl.vektis.www.Vz3738BindingStub.<clinit>(Vz3738BindingStub.java:22)
        at
nl.vektis.www.Vz3738ServiceLocator.getVz3738Port(Vz3738ServiceLocator.java:57)
        at
nl.vektis.www.Vz3738ServiceLocator.getVz3738Port(Vz3738ServiceLocator.java:51)
        at nl.vektis.www.VecozoSOAP.checkInsurance3738(VecozoSOAP.java:124)
        at
nl.yellowstone.zbc.internal.office.referrals.ReferralPatientSearchForm.doPost(ReferralPatientSearchForm.java:84)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:713)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
        at
org.apache.geronimo.tomcat.valve.DefaultSubjectValve.invoke(DefaultSubjectValve.java:56)
        at
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
        at
org.apache.geronimo.tomcat.GeronimoStandardContext$SystemMethodValve.invoke(GeronimoStandardContext.java:406)
        at
org.apache.geronimo.tomcat.valve.GeronimoBeforeAfterValve.invoke(GeronimoBeforeAfterValve.java:47)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:568)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
        at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
        at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
        at
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
        at java.lang.Thread.run(Unknown Source)
valid: 0
Security for Vecozo initialized!!!
Changed Vecozo security!!!
This is in Vz3738Servicelocator.java - Line 56
2009-07-24 16:20:01,853 ERROR [[ReferralPatientSearchForm]]
Servlet.service() for servlet ReferralPatientSearchForm threw exception
java.lang.NoClassDefFoundError: Could not initialize class
nl.vektis.www.Vz3738BindingStub
        at
nl.vektis.www.Vz3738ServiceLocator.getVz3738Port(Vz3738ServiceLocator.java:57)
        at
nl.vektis.www.Vz3738ServiceLocator.getVz3738Port(Vz3738ServiceLocator.java:51)
        at nl.vektis.www.VecozoSOAP.checkInsurance3738(VecozoSOAP.java:124)
        at
nl.yellowstone.zbc.internal.office.referrals.ReferralPatientSearchForm.doPost(ReferralPatientSearchForm.java:84)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:713)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
        at
org.apache.geronimo.tomcat.valve.DefaultSubjectValve.invoke(DefaultSubjectValve.java:56)
        at
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
        at
org.apache.geronimo.tomcat.GeronimoStandardContext$SystemMethodValve.invoke(GeronimoStandardContext.java:406)
        at
org.apache.geronimo.tomcat.valve.GeronimoBeforeAfterValve.invoke(GeronimoBeforeAfterValve.java:47)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:568)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
        at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
        at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
        at
org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
        at java.lang.Thread.run(Unknown Source)


I see that there is a difference in the errors between the first and second
request. And the error circumstances are similar like in that error before
i.e. one class trying to call a function from another class within the same
project.
There are also a few debug messages in there.

Is all of this somehow connected?
I just can't make sense of it. :(


Thanks for helping.





kevan wrote:
> 
> 
> On Jul 22, 2009, at 12:23 PM, David Jencks wrote:
> 
>> There are two possibilities I can think of right now:
>>
>> 1. Something is calling Environment.setApplicationProperties(null)  
>> which produces a NullPointerException before the System.out can tell  
>> you about it.  This seems unlikely but is easy to check with another  
>> System.out. I guess there might be a clearApplicationProperties()  
>> method also...
>>
>> 2. you have 2 classloaders loading the Environment class.  I don't  
>> really see how this would be happening either but again is pretty  
>> easy to check.
> 
> That was the only "idea" that I had...
> 
> You should be able to reproduce this under the Eclipse Debugger.  
> Launch the server process remotely (i.e. 'bin/geronimo.sh jpda run'),  
> attach the Eclipse process to this server process (e.g. localhost port  
> 8000), set breakpoint(s), and run a deploy.
> 
> --kevan
> 
> 

-- 
View this message in context: http://www.nabble.com/Standalone-deployment-%3Ccross-context%3E-doesn%27t-work-tp24591184s134p24645635.html
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message