I've been trying to look into this but I've had a hard time building Geronimo trunk. It seems to me like the new Apache snapshot repositories are not entirely stable, and that Geronimo is using some old versions that are no longer available.

First OpenEJB-3.1.1-SNAPSHOT is incomplete here:

https://repository.apache.org/content/repositories/snapshots/org/apache/openejb/ejb31-api-experimental/

I changed Geronimo to use the 3.1.1 release of OpenEJB to work around this.

Then there's a problem with ActiveMQ-5.3-SNAPSHOT that gave me this error:

Project ID: null:activemq-core:bundle:null
Reason: Cannot find parent: org.apache.activemq:activemq-parent for project: null:activemq-core:bundle:null for project null:activemq-core:bundle:null

I checked out ActiveMQ trunk and built it locally which seems to work.

Then jetty-ajp from Jetty-7.0.0.M2-SNAPSHOT is no longer available here:

http://oss.sonatype.org/content/repositories/jetty-snapshots/org/eclipse/jetty/jetty-ajp/

I upgraded Geronimo to use the 7.0.0.M3 snapshot of Jetty, which makes it build.

Now there's a problem with building the activemq-webconsole plugin (plugins/activemq/activemq-webconsole).

Error assembling WAR: Deployment descriptor: /home/jotta/ws/geronimo/plugins/activemq/activemq-webconsole/target/activemq-webconsole-2.2-SNAPSHOT/WEB-INF/web.xml does not exist.

I also tried using Jetty6 but I'm getting the same error. However I found that activemq-webconsole wasn't used, so I disabled the activemq-webconsole plugins, and was finally able to build the server.

Now to start the server I tried "mvn geronimo:start -Doptions=morememory -N", but this failed because:

The plugin 'org.apache.maven.plugins:maven-geronimo-plugin' does not exist or no valid version could be found

I then tried to start Geronimo without the Maven plugin, but it failed, probably because I changed the Jetty version to M3. I then rebuilt Geronimo using the jetty6 switch, and now it starts fine!

I'm not able to reproduce this easily. I do get errors when limiting the number of open files below that required by Geronimo, but no spamming of the log file so far.

I'll try to do some more tests later with an application that opens too many files on purpose. The testing I did here was with a "pure" Geronimo server.

Trygve

On Fri, Jun 5, 2009 at 12:20 PM, Trygve Hardersen <trygve@jotta.no> wrote:
I'll do some tests and let you know what happens.

Trygve


On Fri, Jun 5, 2009 at 12:17 PM, Shawn Jiang <genspring@gmail.com> wrote:
Do you experience the same problem when you just deploy the web app into a single geronimo instead of WADI clustering ?


On Fri, Jun 5, 2009 at 6:00 PM, Trygve Hardersen <trygve@jotta.no> wrote:
Also note that the configuration where this happened had WADI clustering enabled for 2 web apps. Not sure if that had any impact.

Trygve


On Fri, Jun 5, 2009 at 11:49 AM, Trygve Hardersen <trygve@jotta.no> wrote:
Sorry, we're using 2.2-SNAPSHOT, revision 779302 with jetty6 instead of jetty7.

Trygve


On Fri, Jun 5, 2009 at 11:45 AM, Shawn Jiang <genspring@gmail.com> wrote:
What's version are you using ?

There was a fixed JIRA related to this before:https://issues.apache.org/jira/browse/GERONIMO-3151

On Fri, Jun 5, 2009 at 5:36 PM, Trygve Hardersen <trygve@jotta.no> wrote:
java.io.IOException: Too many open files



--
Shawn





--
Shawn