geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Delos <dait...@gmail.com>
Subject Re: Eclipse connect to Geronimo on other host
Date Wed, 24 Jun 2009 02:08:43 GMT
Hi Michael

Just as you see, there is no open RMi port in your service, unless you start
the server.

Suppose you have a eclipse and geronimo server in host A, meanwhile, there
is another geronimo server in host B.
Here are the steps to visit remote server:
1) In host A, create a server instance in eclipse, which target to the
server in host A
2) start the server instance in eclipse
3) start the server in host B
4) Once you start up server successfully, double click the server instance
in eclipse to open an editor. In the editor, you can change the server host
into the IP address of host B
5) Then, you can deploy your application to the remote host

Note: it's better that the two servers  are in  the same version

Hope it helps!

2009/6/24 mmike <redeamer@gmx.net>

>
> Hi,
>
> I've configured a new geronimo server in eclipse (3.4.2). The geronimo
> (2.1.4) itself is running on a different server. And now I've troubles to
> connect to the server.
>
> If I got that right, the connection has to be done over RMI service
> (default
> port 1099). But my service does not show this as open port (checked with
> nmap), but on server startup I get the line:
> Listening on ports:
> ...
> 1099 0.0.0.0 RMI Naming
> ...
>
> Can somebody please light this a little bit up for me?!
>
> Sorry for any inconvenience caused by a stupid question, but I'm really new
> to geronimo.
>
> Regards
> Michael
>
> --
> View this message in context:
> http://www.nabble.com/Eclipse-connect-to-Geronimo-on-other-host-tp24167356s134p24167356.html
> Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.
>
>


-- 
Best Regards,

Delos

Mime
View raw message