geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From p...@gmfoto.de
Subject icefaces and geronimo 2.1.4
Date Sun, 14 Jun 2009 20:57:15 GMT

Hi All,

today i tried to use icefaces with my geronimo 2.1.4

i run allways in an error:
2009-06-14 17:33:24,851 ERROR [[/test]] Servlet /test threw load()
exception
java.lang.IllegalStateException : No Factories configured for this
Application. This happens if the faces-initialization does not work at all
- make sure that you properly include all configuration settings necessary
for a basic faces application and that all the necessary libs are included.
Also check the logging output of your web application and your container
for any exceptions!
If you did that and find nothing, the mistake might be due to the fact that
you use some special web-containers which do not support registering
context-listeners via TLD files and a context listener is not setup in your
web.xml.
A typical config looks like this;
<listener>
  <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</listener-class>

</listener>

Has anybody a solution for this issue?

Thx Thomas


GM-Foto GmbH
Thomas Poth

IT-Manager
Tel.: 0049-69-238570-0
Fax: 0049-69-238570-30
Mail: poth@gmfoto.de
Web: www.gmfoto.de


Mime
View raw message