geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Error when deploying a realm with a login module:org.apache.geronimo.openejb.OpenejbRemoteLoginModule
Date Tue, 09 Jun 2009 15:41:20 GMT
I don't see anything obviously wrong.

It _really_ shouldn't make a difference but could you try using client- 
security instead of j2ee-security in your plan and also include the  
geronimo version in the dependency?

Also, what is the geronimo version?

thanks
david jencks

On Jun 9, 2009, at 6:16 AM, Rodger wrote:

> My realm deploy plan named security_realm.xml is as follow:
> =====================================================================
> <module xmlns="http://geronimo.apache.org/xml/ns/deployment-1.2">
>     <environment>
>         <moduleId>
>             <groupId>console.realm</groupId>
>             <artifactId>remote-openejb-realm</artifactId>
>             <version>1.0</version>
>             <type>car</type>
>         </moduleId>
>         <dependencies>
>             <dependency>
>                 <groupId>org.apache.geronimo.framework</groupId>
>                 <artifactId>j2ee-security</artifactId>
>                 <type>car</type>
>             </dependency>
>         </dependencies>
>     </environment>
>     <gbean name="remote-openejb-realm"  
> class="org.apache.geronimo.security.realm.GenericSecurityRealm"  
> xsi:type="dep:gbeanType" xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2

> " xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
>         <attribute name="realmName">remote-openejb-realm</attribute>
>         <reference name="ServerInfo">
>             <name>ServerInfo</name>
>         </reference>
>         <xml-reference name="LoginModuleConfiguration">
>             <log:login-config xmlns:log="http://geronimo.apache.org/xml/ns/loginconfig-2.0

> ">
>                 <log:login-module control-flag="REQUIRED" wrap- 
> principals="false">
>                     <log:login-domain-name>remote-openejb-realm</ 
> log:login-domain-name>
>                     <log:login-module- 
> class>org.apache.geronimo.openejb.OpenejbRemoteLoginModule</ 
> log:login-module-class>
>                     <log:option name="RemoteSecurityRealm">test- 
> realm</log:option>
>                     <log:option name="ServerURI">ejbd://localhost: 
> 4201</log:option>
>                 </log:login-module>
>             </log:login-config>
>         </xml-reference>
>     </gbean>
> </module>
> = 
> = 
> = 
> ======================================================================
> When
> bin>java -jar deployer.jar deploy d:\security_realm.xml
> The error is as follows:
>     Error: Operation failed: start of
>     console.realm/remote-openejb-realm/1.0/car failed
>
>         Unknown start exception
>
>         Configuration console.realm/remote-openejb-realm/1.0/car  
> failed to
>     start due to the following reasons:
>
>       The service
>     ServiceModule=console.realm/remote-openejb-realm/1.0/ 
> car,j2eeType=SecurityRe
> alm,name=remote-openejb-realm
>     did not start because
>     org.apache.geronimo.openejb.OpenejbRemoteLoginModule in  
> classloader
>     console.realm/remote-openejb-realm/1.0/car
>
> It seems that the system can not find the class  
> org.apache.geronimo.openejb.OpenejbRemoteLoginModule.
> I get the reference from http://cwiki.apache.org/GMOxDOC22/configuring-javaee-app-client-security.html
> -- 
> Best Regards,
> Rodger.


Mime
View raw message